Skip to content

← Public intelligence

Maven package

org.opennms:opennms-webapp

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.8MavenPublished

    OpenNMS Cross-site Scripting vulnerability

    CVE-2023-40314 · GHSA-c6xw-hg9q-3c9f

    Affected
    • Maven org.opennms:opennms-webapp < 32.0.5
    Fixed in
    32.0.5· Vendor fix available
    Issue
    Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

    Recommended action: Upgrade to 32.0.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.7MavenPublished

    OpenNMS vulnerable to Cross-site Scripting

    CVE-2023-40311 · GHSA-qfw7-pfxx-h9q2

    Affected
    • Maven org.opennms:opennms-webapp >= 31.0.8, < 32.0.2
    Fixed in
    32.0.2· Vendor fix available
    Issue
    Multiple stored XSS were found on different JSP files with unsanitized parameters in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms that allow an attacker to store on database and then load on JSPs or Angular templates. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Jordi Miralles Comins for reporting this issue.

    Recommended action: Upgrade to 32.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.7MavenPublished

    OpenNMS vulnerable to Cross-site Scripting

    CVE-2023-40312 · GHSA-chgr-j2p9-jjh8

    Affected
    • Maven org.opennms:opennms-webapp >= 31.0.8, < 32.0.2
    Fixed in
    32.0.2· Vendor fix available
    Issue
    Multiple reflected XSS were found on different JSP files with unsanitized parameters in OpenNMS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms that an attacker can modify to craft a malicious XSS payload. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Jordi Miralles Comins for reporting this issue.

    Recommended action: Upgrade to 32.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 6.7MavenPublished

    OpenNMS Meridian and Horizon vulnerable to Cross-Site Request Forgery

    CVE-2023-0870 · GHSA-jxr6-7qg5-8wv6

    Affected
    • Maven org.opennms:opennms-webapp < 31.0.6
    Fixed in
    31.0.6· Vendor fix available
    Issue
    A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

    Recommended action: Upgrade to 31.0.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 6.1MavenPublished

    OpenNMS Meridian and Horizon vulnerable to Cross-site Scripting

    CVE-2023-0868 · GHSA-g57g-rvpg-2f2c

    Affected
    • Maven org.opennms:opennms-webapp < 31.0.4
    Fixed in
    31.0.4· Vendor fix available
    Issue
    Reflected cross-site scripting in graph results in multiple versions of OpenNMS Meridian and Horizon could allow an attacker access to steal session cookies.

    Recommended action: Upgrade to 31.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →