OpenNMS vulnerable to Cross-site Scripting
CVE-2023-40311GHSA-qfw7-pfxx-h9q2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opennms:opennms-webapp 32.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.opennms:opennms-webapp
- Affected
- >= 31.0.8, < 32.0.2
- Fixed in
- 32.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qfw7-pfxx-h9q2 lists affected ranges: Maven org.opennms:opennms-webapp >=31.0.8 <32.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.7 · CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2023-40311: 0.74% estimated exploitation activity in the next 30 days; percentile 54.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Multiple stored XSS were found on different JSP files with unsanitized parameters in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms that allow an attacker to store on database and then load on JSPs or Angular templates. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Jordi Miralles Comins for reporting this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qfw7-pfxx-h9q2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-40311 Advisory: OpenNMS vulnerable to Cross-site Scripting IDs: CVE-2023-40311, GHSA-qfw7-pfxx-h9q2 Record: https://patchnext.com/advisories/cve-2023-40311 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.opennms:opennms-webapp 32.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.opennms:opennms-webapp: affected >= 31.0.8, < 32.0.2; fixed in 32.0.2 ## Suggested inspection (read-only) - Maven org.opennms:opennms-webapp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.opennms:opennms-webapp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qfw7-pfxx-h9q2 (GitHub-reviewed advisory GHSA-qfw7-pfxx-h9q2 lists affected ranges: Maven org.opennms:opennms-webapp >=31.0.8 <32.0.2) Commands are suggestions: review each one before running it.
Loading voting…