Skip to content

← Public intelligence

Maven package

org.openidentityplatform.openam:openam-scripting

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    OpenAM Authenticated RCE via Groovy Sandbox Escape

    CVE-2026-47424 · GHSA-69j4-qvqr-hpw3

    Affected
    • Maven org.openidentityplatform.openam:openam-scripting <= 16.0.6
    Fixed in
    16.1.1· Vendor fix available
    Issue
    Description A Protection Mechanism Failure (CWE-693) in OpenAM's server-side scripting sandbox allows an authenticated script author execute operating-system commands from the OpenAM JVM with the default class allow and deny lists. This impacts OpenAM Community Edition through version 16.0.6. This issue was patched in version 16.1.1. Impact An authenticated user (for example, a realm admin) who can create or edit server-side scripts for an executed context can run OS commands as the OpenAM application server admin. For a sub-realm RealmAdmin, this crosses the documented boundary from realm-scoped administration to JVM/host execution, effectively compromising the whole OpenAM process and every realm it serves. The sandbox is the only code-level defense between a realm script author and arbitrary JVM/OS execution. Patch This has been patched in OpenAM Community Edition version 16.1.1. Users are encouraged to update to the latest release.

    Recommended action: Upgrade to 16.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →