OpenAM Authenticated RCE via Groovy Sandbox Escape
CVE-2026-47424GHSA-69j4-qvqr-hpw3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.openidentityplatform.openam:openam-scripting 16.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.openidentityplatform.openam:openam-scripting
- Affected
- <= 16.0.6
- Fixed in
- 16.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-69j4-qvqr-hpw3 lists affected ranges: Maven org.openidentityplatform.openam:openam-scripting >=0 <=16.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-47424: 0.48% estimated exploitation activity in the next 30 days; percentile 41.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Description A Protection Mechanism Failure (CWE-693) in OpenAM's server-side scripting sandbox allows an authenticated script author execute operating-system commands from the OpenAM JVM with the default class allow and deny lists. This impacts OpenAM Community Edition through version 16.0.6. This issue was patched in version 16.1.1. Impact An authenticated user (for example, a realm admin) who can create or edit server-side scripts for an executed context can run OS commands as the OpenAM application server admin. For a sub-realm RealmAdmin, this crosses the documented boundary from realm-scoped administration to JVM/host execution, effectively compromising the whole OpenAM process and every realm it serves. The sandbox is the only code-level defense between a realm script author and arbitrary JVM/OS execution. Patch This has been patched in OpenAM Community Edition version 16.1.1. Users are encouraged to update to the latest release.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-69j4-qvqr-hpw3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47424 Advisory: OpenAM Authenticated RCE via Groovy Sandbox Escape IDs: CVE-2026-47424, GHSA-69j4-qvqr-hpw3 Record: https://patchnext.com/advisories/cve-2026-47424 (revision 1, source checked 26 Oct 2026, 16:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.openidentityplatform.openam:openam-scripting 16.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.openidentityplatform.openam:openam-scripting: affected <= 16.0.6; fixed in 16.1.1 ## Suggested inspection (read-only) - Maven org.openidentityplatform.openam:openam-scripting: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.openidentityplatform.openam:openam-scripting. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-69j4-qvqr-hpw3 (GitHub-reviewed advisory GHSA-69j4-qvqr-hpw3 lists affected ranges: Maven org.openidentityplatform.openam:openam-scripting >=0 <=16.0.6) Commands are suggestions: review each one before running it.
Loading voting…