Skip to content

← Public intelligence

Maven package

org.jvnet.hudson.plugins:favorite

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8MavenPublished

    Jenkins Favorite Plugin vulnerable to Cross-Site Request Forgery

    CVE-2017-1000244 · GHSA-jqwh-jrpg-5j3h

    Affected
    • Maven org.jvnet.hudson.plugins:favorite <= 2.2.0
    Fixed in
    2.3.2· Vendor fix available
    Issue
    Jenkins Favorite Plugin version 2.2.0 and older is vulnerable to CSRF resulting in data modification.

    Recommended action: Upgrade to 2.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.3MavenPublished

    Missing permission check in Jenkins Favorite Plugin

    CVE-2017-1000243 · GHSA-268v-2qq7-84pf

    Affected
    • Maven org.jvnet.hudson.plugins:favorite < 2.3.0
    Fixed in
    2.3.0· Vendor fix available
    Issue
    Jenkins Favorite Plugin up to and including 2.1.0 does not perform permission checks when changing favorite status, allowing any user to set any other user's favorites

    Recommended action: Upgrade to 2.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.4MavenPublished

    Stored Cross-site Scripting vulnerability in Jenkins Favorite Plugin

    CVE-2022-27196 · GHSA-874r-46c6-7p4r

    Affected
    • Maven org.jvnet.hudson.plugins:favorite < 2.4.1
    Fixed in
    2.4.1· Vendor fix available
    Issue
    Jenkins Favorite Plugin 2.4.0 and earlier does not escape the names of jobs in the favorite column, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure or Item/Create permissions.

    Recommended action: Upgrade to 2.4.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →