Jenkins Favorite Plugin vulnerable to Cross-Site Request Forgery
CVE-2017-1000244GHSA-jqwh-jrpg-5j3h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jvnet.hudson.plugins:favorite 2.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jvnet.hudson.plugins:favorite
- Affected
- <= 2.2.0
- Fixed in
- 2.3.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jqwh-jrpg-5j3h lists affected ranges: Maven org.jvnet.hudson.plugins:favorite >=0 <=2.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-1000244: 0.83% estimated exploitation activity in the next 30 days; percentile 57.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Favorite Plugin version 2.2.0 and older is vulnerable to CSRF resulting in data modification.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jqwh-jrpg-5j3h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-1000244 Advisory: Jenkins Favorite Plugin vulnerable to Cross-Site Request Forgery IDs: CVE-2017-1000244, GHSA-jqwh-jrpg-5j3h Record: https://patchnext.com/advisories/cve-2017-1000244 (revision 1, source checked 26 Oct 2026, 16:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jvnet.hudson.plugins:favorite 2.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jvnet.hudson.plugins:favorite: affected <= 2.2.0; fixed in 2.3.2 ## Suggested inspection (read-only) - Maven org.jvnet.hudson.plugins:favorite: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jvnet.hudson.plugins:favorite. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jqwh-jrpg-5j3h (GitHub-reviewed advisory GHSA-jqwh-jrpg-5j3h lists affected ranges: Maven org.jvnet.hudson.plugins:favorite >=0 <=2.2.0) Commands are suggestions: review each one before running it.
Loading voting…