High, CVSS 8.8MavenPublished
RCE vulnerability in Jenkins Yaml Axis Plugin
CVE-2020-2179 · GHSA-324h-2v7h-q3xx
- Affected
- Maven org.jenkins-ci.plugins:yaml-axis <= 0.2.0
- Fixed in
- 0.2.1· Vendor fix available
- Issue
- Yaml Axis Plugin 0.2.0 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types. This results in a remote code execution (RCE) vulnerability exploitable by users able to configure a multi-configuration (Matrix) job, or control the contents of a previously configured job’s SCM repository. Yaml Axis Plugin 0.2.1 configures its YAML parser to only instantiate safe types.
Recommended action: Upgrade to 0.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.