RCE vulnerability in Jenkins Yaml Axis Plugin
CVE-2020-2179GHSA-324h-2v7h-q3xx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:yaml-axis 0.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:yaml-axis
- Affected
- <= 0.2.0
- Fixed in
- 0.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-324h-2v7h-q3xx lists affected ranges: Maven org.jenkins-ci.plugins:yaml-axis >=0 <=0.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-2179: 2.87% estimated exploitation activity in the next 30 days; percentile 86.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Yaml Axis Plugin 0.2.0 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types. This results in a remote code execution (RCE) vulnerability exploitable by users able to configure a multi-configuration (Matrix) job, or control the contents of a previously configured job’s SCM repository. Yaml Axis Plugin 0.2.1 configures its YAML parser to only instantiate safe types.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-324h-2v7h-q3xx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-2179 Advisory: RCE vulnerability in Jenkins Yaml Axis Plugin IDs: CVE-2020-2179, GHSA-324h-2v7h-q3xx Record: https://patchnext.com/advisories/cve-2020-2179 (revision 1, source checked 26 Oct 2026, 16:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:yaml-axis 0.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:yaml-axis: affected <= 0.2.0; fixed in 0.2.1 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:yaml-axis: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:yaml-axis. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-324h-2v7h-q3xx (GitHub-reviewed advisory GHSA-324h-2v7h-q3xx lists affected ranges: Maven org.jenkins-ci.plugins:yaml-axis >=0 <=0.2.0) Commands are suggestions: review each one before running it.
Loading voting…