Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:scriptler

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4MavenPublished

    Stored XSS vulnerability in Jenkins Scriptler Plugin

    CVE-2021-21700 · GHSA-f9gf-2q87-5m44

    Affected
    • Maven org.jenkins-ci.plugins:scriptler <= 3.3
    Fixed in
    3.4· Vendor fix available
    Issue
    Jenkins Scriptler Plugin 3.3 and earlier does not escape the name of scripts on the UI when asking to confirm their deletion. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to create Scriptler scripts. Jenkins Scriptler Plugin 3.4 escapes the name of scripts on the UI when asking to confirm their deletion.

    Recommended action: Upgrade to 3.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.4MavenPublished

    Stored XSS vulnerability in Jenkins Scriptler Plugin

    CVE-2021-21667 · GHSA-p479-rwhp-rwjx

    Affected
    • Maven org.jenkins-ci.plugins:scriptler < 3.3
    Fixed in
    3.3· Vendor fix available
    Issue
    Jenkins Scriptler Plugin 3.2 and earlier does not escape parameter names shown in job configuration forms. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Scriptler/Configure permission. Jenkins Scriptler Plugin 3.3 escapes parameter names shown in job configuration forms.

    Recommended action: Upgrade to 3.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.4MavenPublished

    Stored XSS vulnerability in Jenkins Scriptler Plugin

    CVE-2021-21668 · GHSA-5c6c-w4c4-vgvx

    Affected
    • Maven org.jenkins-ci.plugins:scriptler < 3.2
    Fixed in
    3.2· Vendor fix available
    Issue
    Jenkins Scriptler Plugin 3.1 and earlier does not escape script content. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Scriptler/Configure permission. Jenkins Scriptler Plugin 3.2 escapes script content.

    Recommended action: Upgrade to 3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →