Stored XSS vulnerability in Jenkins Scriptler Plugin
CVE-2021-21668GHSA-5c6c-w4c4-vgvx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:scriptler 3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:scriptler
- Affected
- < 3.2
- Fixed in
- 3.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5c6c-w4c4-vgvx lists affected ranges: Maven org.jenkins-ci.plugins:scriptler >=0 <3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-21668: 76.02% estimated exploitation activity in the next 30 days; percentile 99.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Scriptler Plugin 3.1 and earlier does not escape script content. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Scriptler/Configure permission. Jenkins Scriptler Plugin 3.2 escapes script content.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5c6c-w4c4-vgvx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21668 Advisory: Stored XSS vulnerability in Jenkins Scriptler Plugin IDs: CVE-2021-21668, GHSA-5c6c-w4c4-vgvx Record: https://patchnext.com/advisories/cve-2021-21668 (revision 1, source checked 26 Oct 2026, 16:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:scriptler 3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:scriptler: affected < 3.2; fixed in 3.2 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:scriptler: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:scriptler. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5c6c-w4c4-vgvx (GitHub-reviewed advisory GHSA-5c6c-w4c4-vgvx lists affected ranges: Maven org.jenkins-ci.plugins:scriptler >=0 <3.2) Commands are suggestions: review each one before running it.
Loading voting…