Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:pipeline-build-step

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4MavenPublished

    Cross-site Scripting in Jenkins Pipeline: Build Step Plugin

    CVE-2023-25762 · GHSA-9j65-3f2q-8q2r

    Affected
    • Maven org.jenkins-ci.plugins:pipeline-build-step <= 2.18
    Fixed in
    2.18.1· Vendor fix available
    Issue
    Jenkins Pipeline: Build Step Plugin 2.18 and earlier does not escape job names in a JavaScript expression used in the Pipeline Snippet Generator, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control job names.

    Recommended action: Upgrade to 2.18.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.3MavenPublished

    Users with Overall/Read access can enumerate credential IDs in Pipeline GitHub Notify Step Plugin

    CVE-2020-2118 · GHSA-8p4m-62gp-33j4

    Affected
    • Maven org.jenkins-ci.plugins:pipeline-build-step < 1.0.5
    Fixed in
    1.0.5· Vendor fix available
    Issue
    Pipeline GitHub Notify Step Plugin 1.0.4 and earlier provides a list of applicable credential IDs to allow users configuring the plugin to select the one to use. This functionality does not correctly check permissions, allowing any user with Overall/Read permission to get a list of valid credentials IDs. Those can be used as part of an attack to capture the credentials using another vulnerability. An enumeration of credentials IDs in Pipeline GitHub Notify Step Plugin 1.0.5 requires the permission to configure a project.

    Recommended action: Upgrade to 1.0.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.3MavenPublished

    Jenkins Build Step Plugin fails to check Item/Build permission

    CVE-2017-1000089 · GHSA-8jx9-7j5m-79x4

    Affected
    • Maven org.jenkins-ci.plugins:pipeline-build-step <= 2.5
    Fixed in
    2.5.1· Vendor fix available
    Issue
    Builds in Jenkins are associated with an authentication that controls the permissions that the build has to interact with other elements in Jenkins. The Pipeline: Build Step Plugin did not check the build authentication it was running as and allowed triggering any other project in Jenkins.

    Recommended action: Upgrade to 2.5.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 4.3MavenPublished

    Password parameter default values exposed by Jenkins Pipeline: Build Step Plugin

    CVE-2022-25184 · GHSA-g84f-cmc8-682c

    Affected
    • Maven org.jenkins-ci.plugins:pipeline-build-step < 2.15.1
    Fixed in
    2.15.1· Vendor fix available
    Issue
    Jenkins Pipeline: Build Step Plugin 2.15 and earlier reveals password parameter default values when generating a pipeline script using the Pipeline Snippet Generator, allowing attackers with Item/Read permission to retrieve the default password parameter value from jobs.

    Recommended action: Upgrade to 2.15.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →