Users with Overall/Read access can enumerate credential IDs in Pipeline GitHub Notify Step Plugin
CVE-2020-2118GHSA-8p4m-62gp-33j4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:pipeline-build-step 1.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:pipeline-build-step
- Affected
- < 1.0.5
- Fixed in
- 1.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8p4m-62gp-33j4 lists affected ranges: Maven org.jenkins-ci.plugins:pipeline-build-step >=0 <1.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2020-2118: 0.68% estimated exploitation activity in the next 30 days; percentile 52.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Pipeline GitHub Notify Step Plugin 1.0.4 and earlier provides a list of applicable credential IDs to allow users configuring the plugin to select the one to use. This functionality does not correctly check permissions, allowing any user with Overall/Read permission to get a list of valid credentials IDs. Those can be used as part of an attack to capture the credentials using another vulnerability. An enumeration of credentials IDs in Pipeline GitHub Notify Step Plugin 1.0.5 requires the permission to configure a project.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8p4m-62gp-33j4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-2118 Advisory: Users with Overall/Read access can enumerate credential IDs in Pipeline GitHub Notify Step Plugin IDs: CVE-2020-2118, GHSA-8p4m-62gp-33j4 Record: https://patchnext.com/advisories/cve-2020-2118 (revision 1, source checked 26 Oct 2026, 16:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:pipeline-build-step 1.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:pipeline-build-step: affected < 1.0.5; fixed in 1.0.5 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:pipeline-build-step: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:pipeline-build-step. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8p4m-62gp-33j4 (GitHub-reviewed advisory GHSA-8p4m-62gp-33j4 lists affected ranges: Maven org.jenkins-ci.plugins:pipeline-build-step >=0 <1.0.5) Commands are suggestions: review each one before running it.
Loading voting…