Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:cas-plugin

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8MavenPublished

    Jenkins CAS Plugin Session Fixation vulnerability

    CVE-2023-32997 · GHSA-hjh8-9gxh-cx4x

    Affected
    • Maven org.jenkins-ci.plugins:cas-plugin < 1.6.3
    Fixed in
    1.6.3· Vendor fix available
    Issue
    Jenkins CAS Plugin 1.6.2 and earlier does not invalidate the existing session on login. This allows attackers to use social engineering techniques to gain administrator access to Jenkins. CAS Plugin 1.6.3 invalidates the existing session on login.

    Recommended action: Upgrade to 1.6.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.1MavenPublished

    Open redirect vulnerability in Jenkins CAS Plugin

    CVE-2021-21673 · GHSA-2vvr-5757-qp87

    Affected
    • Maven org.jenkins-ci.plugins:cas-plugin <= 1.6.0
    Fixed in
    1.6.1· Vendor fix available
    Issue
    Jenkins CAS Plugin 1.6.0 and earlier improperly determines that a redirect URL after login is legitimately pointing to Jenkins. This allows attackers to perform phishing attacks by having users go to a Jenkins URL that will forward them to a different site after successful authentication. Jenkins CAS Plugin 1.6.1 only redirects to relative (Jenkins) URLs.

    Recommended action: Upgrade to 1.6.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.4MavenPublished

    Jenkins CAS Plugin Server-Side Request Forgery vulnerability

    CVE-2018-1000188 · GHSA-f8r7-7hv9-7f43

    Affected
    • Maven org.jenkins-ci.plugins:cas-plugin <= 1.4.1
    Fixed in
    1.4.2· Vendor fix available
    Issue
    A server-side request forgery vulnerability exists in Jenkins CAS Plugin 1.4.1 and older in CasSecurityRealm.java that allows attackers with Overall/Read access to cause Jenkins to send a GET request to a specified URL. Additionally, this form validation method did not require POST requests, resulting in a CSRF vulnerability. As of version 1.4.2, this form validation method requires POST requests and the Overall/Administer permission.

    Recommended action: Upgrade to 1.4.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →