Jenkins CAS Plugin Session Fixation vulnerability
CVE-2023-32997GHSA-hjh8-9gxh-cx4x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:cas-plugin 1.6.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:cas-plugin
- Affected
- < 1.6.3
- Fixed in
- 1.6.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hjh8-9gxh-cx4x lists affected ranges: Maven org.jenkins-ci.plugins:cas-plugin >=0 <1.6.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-32997: 0.79% estimated exploitation activity in the next 30 days; percentile 56.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins CAS Plugin 1.6.2 and earlier does not invalidate the existing session on login. This allows attackers to use social engineering techniques to gain administrator access to Jenkins. CAS Plugin 1.6.3 invalidates the existing session on login.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hjh8-9gxh-cx4x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-32997 Advisory: Jenkins CAS Plugin Session Fixation vulnerability IDs: CVE-2023-32997, GHSA-hjh8-9gxh-cx4x Record: https://patchnext.com/advisories/cve-2023-32997 (revision 1, source checked 26 Oct 2026, 16:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:cas-plugin 1.6.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:cas-plugin: affected < 1.6.3; fixed in 1.6.3 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:cas-plugin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:cas-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hjh8-9gxh-cx4x (GitHub-reviewed advisory GHSA-hjh8-9gxh-cx4x lists affected ranges: Maven org.jenkins-ci.plugins:cas-plugin >=0 <1.6.3) Commands are suggestions: review each one before running it.
Loading voting…