Skip to content

← Public intelligence

Maven package

org.jenkins-ci.main:cli

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Jenkins has a Denial of service vulnerability in HTTP-based CLI

    CVE-2025-67635 · GHSA-9p56-p6mw-w8qc

    Affected
    • Maven org.jenkins-ci.main:cli >= 2.529, < 2.541; < 2.528.3
    Fixed in
    2.5412.528.3· Vendor fix available
    Issue
    Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI connections when the connection stream becomes corrupted, allowing unauthenticated attackers to cause a denial of service.

    Recommended action: Upgrade to 2.541 or 2.528.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8MavenPublished

    Jenkins CLI Deserialization of Untrusted Data vulnerability

    CVE-2015-8103 · GHSA-wfw7-6632-xcv2

    Affected
    • Maven org.jenkins-ci.main:cli < 1.625.2; >= 1.626, < 1.638
    Fixed in
    1.6381.625.2· Vendor fix available
    Issue
    The Jenkins CLI subsystem in Jenkins before 1.638 and LTS before 1.625.2 allows remote attackers to execute arbitrary code via a crafted serialized Java object, related to a problematic webapps/ROOT/WEB-INF/lib/commons-collections-.jar file and the "Groovy variant in ysoserial".

    Recommended action: Upgrade to 1.638 or 1.625.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →