Jenkins CLI Deserialization of Untrusted Data vulnerability
CVE-2015-8103GHSA-wfw7-6632-xcv2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.main:cli 1.638, 1.625.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.main:cli
- Affected
- < 1.625.2>= 1.626, < 1.638
- Fixed in
- 1.638, 1.625.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wfw7-6632-xcv2 lists affected ranges: Maven org.jenkins-ci.main:cli >=0 =1.626 <1.638
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2015-8103: 91.86% estimated exploitation activity in the next 30 days; percentile 99.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Jenkins CLI subsystem in Jenkins before 1.638 and LTS before 1.625.2 allows remote attackers to execute arbitrary code via a crafted serialized Java object, related to a problematic webapps/ROOT/WEB-INF/lib/commons-collections-.jar file and the "Groovy variant in ysoserial".
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wfw7-6632-xcv2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-8103 Advisory: Jenkins CLI Deserialization of Untrusted Data vulnerability IDs: CVE-2015-8103, GHSA-wfw7-6632-xcv2 Record: https://patchnext.com/advisories/cve-2015-8103 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.main:cli 1.638, 1.625.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.main:cli: affected < 1.625.2; >= 1.626, < 1.638; fixed in 1.638, 1.625.2 ## Suggested inspection (read-only) - Maven org.jenkins-ci.main:cli: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.main:cli. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wfw7-6632-xcv2 (GitHub-reviewed advisory GHSA-wfw7-6632-xcv2 lists affected ranges: Maven org.jenkins-ci.main:cli >=0 =1.626 <1.638) Commands are suggestions: review each one before running it.
Loading voting…