Skip to content

← Public intelligence

Maven package

org.geoserver:gs-wps

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8MavenPublished

    GeoServer RCE due to improper control of generation of code in jai-extJiffle map algebra language

    CVE-2023-35042 · GHSA-59x6-g4jr-4hxc

    Affected
    • Maven org.geoserver:gs-wps < 2.18.6; >= 2.19.0, < 2.19.6; >= 2.20.0, < 2.20.4
    Fixed in
    2.18.62.20.42.19.6· Vendor fix available
    Issue
    GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code via java.lang.Runtime.getRuntime().exec in wps:LiteralData within a wps:Execute request, as exploited in the wild in June 2023. RCE in Jiffle The Jiffle map algebra language, provided by jai-ext, allows efficiently execute map algebra over large images. A vulnerability CVE-2022-24816 has been recently found in Jiffle, that allows a Code Injection to be performed by properly crafting a Jiffle invocation. In the case of GeoServer, the injection can be performed from a remote request. Assessment GeoTools includes the Jiffle language as part of the gt-process-raster-<version module, applications using it should check whether it’s possible to provide a Jiffle script from remote, and if so, upgrade or remove the functionality (see also the GeoServer mitigation, below). The issue is of particular interest for GeoServer users, as GeoServer embeds Jiffle in the base WAR package. Jiffle is available as a OGC…

    Recommended action: Upgrade to 2.20.4, 2.19.6 or 2.18.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →