Skip to content

← Actionable
Critical, CVSS 9.8

GeoServer RCE due to improper control of generation of code in jai-extJiffle map algebra language

CVE-2023-35042GHSA-59x6-g4jr-4hxc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver:gs-wfs 2.20.4, 2.19.6, 2.18.6; org.geoserver:gs-wps 2.20.4, 2.19.6, 2.18.6; org.geoserver:gs-wms 2.20.4, 2.19.6, 2.18.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.geoserver:gs-wfs

    Affected
    < 2.18.6>= 2.19.0, < 2.19.6>= 2.20.0, < 2.20.4
    Fixed in
    2.18.6, 2.20.4, 2.19.6
  • Maven org.geoserver:gs-wps

    Affected
    < 2.18.6>= 2.19.0, < 2.19.6>= 2.20.0, < 2.20.4
    Fixed in
    2.18.6, 2.20.4, 2.19.6
  • Maven org.geoserver:gs-wms

    Affected
    < 2.18.6>= 2.19.0, < 2.19.6>= 2.20.0, < 2.20.4
    Fixed in
    2.18.6, 2.20.4, 2.19.6

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-59x6-g4jr-4hxc lists affected ranges: Maven org.geoserver:gs-wms >=0 =2.19.0 =2.20.0 =0 =2.19.0 =2.20.0 =0 =2.19.0 =2.20.0 <2.20.4

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-35042: 44.82% estimated exploitation activity in the next 30 days; percentile 98.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code via java.lang.Runtime.getRuntime().exec in wps:LiteralData within a wps:Execute request, as exploited in the wild in June 2023. RCE in Jiffle The Jiffle map algebra language, provided by jai-ext, allows efficiently execute map algebra over large images. A vulnerability CVE-2022-24816 has been recently found in Jiffle, that allows a Code Injection to be performed by properly crafting a Jiffle invocation. In the case of GeoServer, the injection can be performed from a remote request. Assessment GeoTools includes the Jiffle language as part of the gt-process-raster-<version module, applications using it should check whether it’s possible to provide a Jiffle script from remote, and if so, upgrade or remove the functionality (see also the GeoServer mitigation, below). The issue is of particular interest for GeoServer users, as GeoServer embeds Jiffle in the base WAR package. Jiffle is available as a OGC…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-59x6-g4jr-4hxc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-35042

Advisory: GeoServer RCE due to improper control of generation of code in jai-ext`Jiffle` map algebra language
IDs: CVE-2023-35042, GHSA-59x6-g4jr-4hxc
Record: https://patchnext.com/advisories/cve-2023-35042 (revision 1, source checked 26 Oct 2026, 16:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.geoserver:gs-wfs 2.20.4, 2.19.6, 2.18.6; org.geoserver:gs-wps 2.20.4, 2.19.6, 2.18.6; org.geoserver:gs-wms 2.20.4, 2.19.6, 2.18.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.geoserver:gs-wfs: affected < 2.18.6; >= 2.19.0, < 2.19.6; >= 2.20.0, < 2.20.4; fixed in 2.18.6, 2.20.4, 2.19.6
- Maven org.geoserver:gs-wps: affected < 2.18.6; >= 2.19.0, < 2.19.6; >= 2.20.0, < 2.20.4; fixed in 2.18.6, 2.20.4, 2.19.6
- Maven org.geoserver:gs-wms: affected < 2.18.6; >= 2.19.0, < 2.19.6; >= 2.20.0, < 2.20.4; fixed in 2.18.6, 2.20.4, 2.19.6

## Suggested inspection (read-only)
- Maven org.geoserver:gs-wfs: check the installed version with your package manager.
- Maven org.geoserver:gs-wps: check the installed version with your package manager.
- Maven org.geoserver:gs-wms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.geoserver:gs-wfs, org.geoserver:gs-wps, org.geoserver:gs-wms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-59x6-g4jr-4hxc (GitHub-reviewed advisory GHSA-59x6-g4jr-4hxc lists affected ranges: Maven org.geoserver:gs-wms >=0 =2.19.0 =2.20.0 =0 =2.19.0 =2.20.0 =0 =2.19.0 =2.20.0 <2.20.4)

Commands are suggestions: review each one before running it.

Loading voting…