Skip to content

← Public intelligence

Maven package

org.eclipse.jetty.http2:http2-server

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Jetty vulnerable to Invalid HTTP/2 requests that can lead to denial of service

    CVE-2022-2048 · GHSA-wgmr-mf83-7x4j

    Affected
    • Maven org.eclipse.jetty.http2:http2-server < 9.4.47; >= 10.0.0, < 10.0.10; >= 11.0.0, < 11.0.10
    Fixed in
    11.0.109.4.4710.0.10· Vendor fix available
    Issue
    Invalid HTTP/2 requests (for example, invalid URIs) are incorrectly handled by writing a blocking error response directly from the selector thread. If the client manages to exhaust the HTTP/2 flow control window, or TCP congest the connection, the selector thread will be blocked trying to write the error response. If this is repeated for all the selector threads, the server becomes unresponsive, causing the denial of service. Impact A malicious client may render the server unresponsive. Patches The fix is available in Jetty versions 9.4.47. 10.0.10, 11.0.10. Workarounds No workaround available within Jetty itself. One possible workaround is to filter the requests before sending them to Jetty (for example in a proxy) For more information If you have any questions or comments about this advisory: Email us at security@webtide.com.

    Recommended action: Upgrade to 11.0.10, 10.0.10 or 9.4.47 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →