Skip to content

← Actionable
High, CVSS 7.5

Jetty vulnerable to Invalid HTTP/2 requests that can lead to denial of service

CVE-2022-2048GHSA-wgmr-mf83-7x4j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.jetty.http2:http2-server 11.0.10, 10.0.10, 9.4.47), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-2048: 2.56% estimated exploitation activity in the next 30 days; percentile 85.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description Invalid HTTP/2 requests (for example, invalid URIs) are incorrectly handled by writing a blocking error response directly from the selector thread. If the client manages to exhaust the HTTP/2 flow control window, or TCP congest the connection, the selector thread will be blocked trying to write the error response. If this is repeated for all the selector threads, the server becomes unresponsive, causing the denial of service. Impact A malicious client may render the server unresponsive. Patches The fix is available in Jetty versions 9.4.47. 10.0.10, 11.0.10. Workarounds No workaround available within Jetty itself. One possible workaround is to filter the requests before sending them to Jetty (for example in a proxy) For more information If you have any questions or comments about this advisory: Email us at security@webtide.com.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wgmr-mf83-7x4j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-2048

Advisory: Jetty vulnerable to Invalid HTTP/2 requests that can lead to denial of service
IDs: CVE-2022-2048, GHSA-wgmr-mf83-7x4j
Record: https://patchnext.com/advisories/cve-2022-2048 (revision 1, source checked 26 Oct 2026, 16:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.eclipse.jetty.http2:http2-server 11.0.10, 10.0.10, 9.4.47. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.eclipse.jetty.http2:http2-server: affected < 9.4.47; >= 10.0.0, < 10.0.10; >= 11.0.0, < 11.0.10; fixed in 11.0.10, 9.4.47, 10.0.10

## Suggested inspection (read-only)
- Maven org.eclipse.jetty.http2:http2-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.eclipse.jetty.http2:http2-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wgmr-mf83-7x4j (GitHub-reviewed advisory GHSA-wgmr-mf83-7x4j lists affected ranges: Maven org.eclipse.jetty.http2:http2-server >=0 =10.0.0 =11.0.0 <11.0.10)

Commands are suggestions: review each one before running it.

Loading voting…