Skip to content

← Public intelligence

Maven package

org.broadleafcommerce:broadleaf

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1MavenPublished

    Broadleaf vulnerable to Cross-site Scripting

    CVE-2023-33725 · GHSA-3862-fmr3-4f3h

    Affected
    • Maven org.broadleafcommerce:broadleaf >= 5.0.0-GA, < 6.2.7-GA
    Fixed in
    6.2.7-GA· Vendor fix available
    Issue
    Broadleaf 5.x and 6.x (including 5.2.25-GA and 6.2.6-GA) was discovered to contain a cross-site scripting (XSS) vulnerability via a customer signup with a crafted email address. This is fixed in 6.2.7-GA.

    Recommended action: Upgrade to 6.2.7-GA (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →