Broadleaf vulnerable to Cross-site Scripting
CVE-2023-33725GHSA-3862-fmr3-4f3h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.broadleafcommerce:broadleaf 6.2.7-GA), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.broadleafcommerce:broadleaf
- Affected
- >= 5.0.0-GA, < 6.2.7-GA
- Fixed in
- 6.2.7-GA
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3862-fmr3-4f3h lists affected ranges: Maven org.broadleafcommerce:broadleaf >=5.0.0-GA <6.2.7-GA
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-33725: 0.50% estimated exploitation activity in the next 30 days; percentile 42.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Broadleaf 5.x and 6.x (including 5.2.25-GA and 6.2.6-GA) was discovered to contain a cross-site scripting (XSS) vulnerability via a customer signup with a crafted email address. This is fixed in 6.2.7-GA.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3862-fmr3-4f3h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-33725 Advisory: Broadleaf vulnerable to Cross-site Scripting IDs: CVE-2023-33725, GHSA-3862-fmr3-4f3h Record: https://patchnext.com/advisories/cve-2023-33725 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.broadleafcommerce:broadleaf 6.2.7-GA. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.broadleafcommerce:broadleaf: affected >= 5.0.0-GA, < 6.2.7-GA; fixed in 6.2.7-GA ## Suggested inspection (read-only) - Maven org.broadleafcommerce:broadleaf: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.broadleafcommerce:broadleaf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3862-fmr3-4f3h (GitHub-reviewed advisory GHSA-3862-fmr3-4f3h lists affected ranges: Maven org.broadleafcommerce:broadleaf >=5.0.0-GA <6.2.7-GA) Commands are suggestions: review each one before running it.
Loading voting…