Skip to content

← Public intelligence

Maven package

org.apache.zeppelin:zeppelin-server

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Apache Zeppelin exposes server resources to unauthenticated attackers

    CVE-2024-41169 · GHSA-7pgf-ppxw-8624

    Affected
    • Maven org.apache.zeppelin:zeppelin-server >= 0.10.1, < 0.12.0
    Fixed in
    0.12.0· Vendor fix available
    Issue
    The attacker can use the raft server protocol in an unauthenticated way. The attacker can see the server's resources, including directories and files. This issue affects Apache Zeppelin: from 0.10.1 up to 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue by removing the Cluster Interpreter.

    Recommended action: Upgrade to 0.12.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.9MavenPublished

    Apache Zeppelin: LDAP search filter query Injection Vulnerability

    CVE-2024-31867 · GHSA-qmr3-52xf-wmhx

    Affected
    • Maven org.apache.zeppelin:zeppelin-server >= 0.8.2, < 0.11.1
    Fixed in
    0.11.1· Vendor fix available
    Issue
    Improper Input Validation vulnerability in Apache Zeppelin. The attackers can execute malicious queries by setting improper configuration properties to LDAP search filter. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

    Recommended action: Upgrade to 0.11.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.4MavenPublished

    Apache Zeppelin: Cron arbitrary user impersonation with improper privileges

    CVE-2024-31865 · GHSA-g44m-x5h7-fr5q

    Affected
    • Maven org.apache.zeppelin:zeppelin-server >= 0.8.2, < 0.11.1
    Fixed in
    0.11.1· Vendor fix available
    Issue
    Improper Input Validation vulnerability in Apache Zeppelin. The attackers can call updating cron API with invalid or improper privileges so that the notebook can run with the privileges. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

    Recommended action: Upgrade to 0.11.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 6.5MavenPublished

    Apache Zeppelin: Replacing other users notebook, bypassing any permissions

    CVE-2024-31863 · GHSA-m65c-wmw9-vmpp

    Affected
    • Maven org.apache.zeppelin:zeppelin-server >= 0.10.1, < 0.11.0
    Fixed in
    0.11.0· Vendor fix available
    Issue
    Authentication Bypass by Spoofing vulnerability by replacing to exsiting notes in Apache Zeppelin. This issue affects Apache Zeppelin: from 0.10.1 before 0.11.0. Users are recommended to upgrade to version 0.11.0, which fixes the issue.

    Recommended action: Upgrade to 0.11.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 5.3MavenPublished

    Apache Zeppelin: Denial of service with invalid notebook name

    CVE-2024-31862 · GHSA-6623-c6mr-6737

    Affected
    • Maven org.apache.zeppelin:zeppelin-server >= 0.10.1, < 0.11.0
    Fixed in
    0.11.0· Vendor fix available
    Issue
    Improper Input Validation vulnerability in Apache Zeppelin when creating a new note from Zeppelin's UI. This issue affects Apache Zeppelin from 0.10.1 before 0.11.0. Users are recommended to upgrade to version 0.11.0, which fixes the issue.

    Recommended action: Upgrade to 0.11.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 5.3MavenPublished

    Apache Zeppelin Path Traversal vulnerability

    CVE-2024-31860 · GHSA-g64r-xf39-q4p5

    Affected
    • Maven org.apache.zeppelin:zeppelin-server >= 0.9.0, < 0.11.0
    Fixed in
    0.11.0· Vendor fix available
    Issue
    Improper Input Validation vulnerability in Apache Zeppelin. By adding relative path indicators (e.g ..), attackers can see the contents for any files in the filesystem that the server account can access. This issue affects Apache Zeppelin from 0.9.0 before 0.11.0. Users are recommended to upgrade to version 0.11.0, which fixes the issue.

    Recommended action: Upgrade to 0.11.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →