Apache Zeppelin: Replacing other users notebook, bypassing any permissions
CVE-2024-31863GHSA-m65c-wmw9-vmpp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.zeppelin:zeppelin-server 0.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.zeppelin:zeppelin-server
- Affected
- >= 0.10.1, < 0.11.0
- Fixed in
- 0.11.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m65c-wmw9-vmpp lists affected ranges: Maven org.apache.zeppelin:zeppelin-server >=0.10.1 <0.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2024-31863: 1.01% estimated exploitation activity in the next 30 days; percentile 63.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Authentication Bypass by Spoofing vulnerability by replacing to exsiting notes in Apache Zeppelin. This issue affects Apache Zeppelin: from 0.10.1 before 0.11.0. Users are recommended to upgrade to version 0.11.0, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m65c-wmw9-vmpp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-31863 Advisory: Apache Zeppelin: Replacing other users notebook, bypassing any permissions IDs: CVE-2024-31863, GHSA-m65c-wmw9-vmpp Record: https://patchnext.com/advisories/cve-2024-31863 (revision 1, source checked 26 Oct 2026, 16:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.zeppelin:zeppelin-server 0.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.zeppelin:zeppelin-server: affected >= 0.10.1, < 0.11.0; fixed in 0.11.0 ## Suggested inspection (read-only) - Maven org.apache.zeppelin:zeppelin-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.zeppelin:zeppelin-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m65c-wmw9-vmpp (GitHub-reviewed advisory GHSA-m65c-wmw9-vmpp lists affected ranges: Maven org.apache.zeppelin:zeppelin-server >=0.10.1 <0.11.0) Commands are suggestions: review each one before running it.
Loading voting…