Skip to content

← Public intelligence

Maven package

org.apache.zeppelin:zeppelin-interpreter

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Apache Zeppelin exposes server resources to unauthenticated attackers

    CVE-2024-41169 · GHSA-7pgf-ppxw-8624

    Affected
    • Maven org.apache.zeppelin:zeppelin-interpreter >= 0.10.1, < 0.12.0
    Fixed in
    0.12.0· Vendor fix available
    Issue
    The attacker can use the raft server protocol in an unauthenticated way. The attacker can see the server's resources, including directories and files. This issue affects Apache Zeppelin: from 0.10.1 up to 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue by removing the Cluster Interpreter.

    Recommended action: Upgrade to 0.12.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.3MavenPublished

    Improper escaping in Apache Zeppelin

    CVE-2024-31866 · GHSA-86jx-wr74-xr74

    Affected
    • Maven org.apache.zeppelin:zeppelin-interpreter >= 0.8.2, < 0.11.1
    Fixed in
    0.11.1· Vendor fix available
    Issue
    Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. The attackers can execute shell scripts or malicious code by overriding configuration like ZEPPELININTPCLASSPATHOVERRIDES. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

    Recommended action: Upgrade to 0.11.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.3MavenPublished

    Apache Zeppelin vulnerable to cross-site scripting in the helium module

    CVE-2024-31868 · GHSA-rrvf-5w4r-3x7v

    Affected
    • Maven org.apache.zeppelin:zeppelin-interpreter >= 0.8.2, < 0.11.1
    Fixed in
    0.11.1· Vendor fix available
    Issue
    Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. Attackers can modify helium.json and perform cross-site scripting attacks on normal users. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

    Recommended action: Upgrade to 0.11.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →