Apache Zeppelin vulnerable to cross-site scripting in the helium module
CVE-2024-31868GHSA-rrvf-5w4r-3x7v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.zeppelin:zeppelin-interpreter 0.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.zeppelin:zeppelin-interpreter
- Affected
- >= 0.8.2, < 0.11.1
- Fixed in
- 0.11.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rrvf-5w4r-3x7v lists affected ranges: Maven org.apache.zeppelin:zeppelin-interpreter >=0.8.2 <0.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2024-31868: 1.31% estimated exploitation activity in the next 30 days; percentile 70.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. Attackers can modify helium.json and perform cross-site scripting attacks on normal users. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rrvf-5w4r-3x7v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-31868 Advisory: Apache Zeppelin vulnerable to cross-site scripting in the helium module IDs: CVE-2024-31868, GHSA-rrvf-5w4r-3x7v Record: https://patchnext.com/advisories/cve-2024-31868 (revision 1, source checked 26 Oct 2026, 16:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.zeppelin:zeppelin-interpreter 0.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.zeppelin:zeppelin-interpreter: affected >= 0.8.2, < 0.11.1; fixed in 0.11.1 ## Suggested inspection (read-only) - Maven org.apache.zeppelin:zeppelin-interpreter: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.zeppelin:zeppelin-interpreter. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rrvf-5w4r-3x7v (GitHub-reviewed advisory GHSA-rrvf-5w4r-3x7v lists affected ranges: Maven org.apache.zeppelin:zeppelin-interpreter >=0.8.2 <0.11.1) Commands are suggestions: review each one before running it.
Loading voting…