Medium, CVSS 6.1MavenPublished
Cross-site Scripting in Apache UIMA
CVE-2018-8035 · GHSA-vm59-329q-p468
- Affected
- Maven org.apache.uima:uima-ducc-web <= 2.2.2
- Fixed in
- 3.0.0· Vendor fix available
- Issue
- This vulnerability relates to the user's browser processing of DUCC webpage input data.The javascript comprising Apache UIMA DUCC (<= 2.2.2) which runs in the user's browser does not sufficiently filter user supplied inputs, which may result in unintended execution of user supplied javascript code.
Recommended action: Upgrade to 3.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.