Cross-site Scripting in Apache UIMA
CVE-2018-8035GHSA-vm59-329q-p468
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.uima:uima-ducc-web 3.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.uima:uima-ducc-web
- Affected
- <= 2.2.2
- Fixed in
- 3.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vm59-329q-p468 lists affected ranges: Maven org.apache.uima:uima-ducc-web >=0 <=2.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2018-8035: 4.88% estimated exploitation activity in the next 30 days; percentile 92.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This vulnerability relates to the user's browser processing of DUCC webpage input data.The javascript comprising Apache UIMA DUCC (<= 2.2.2) which runs in the user's browser does not sufficiently filter user supplied inputs, which may result in unintended execution of user supplied javascript code.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vm59-329q-p468
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-8035 Advisory: Cross-site Scripting in Apache UIMA IDs: CVE-2018-8035, GHSA-vm59-329q-p468 Record: https://patchnext.com/advisories/cve-2018-8035 (revision 1, source checked 26 Oct 2026, 16:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.uima:uima-ducc-web 3.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.uima:uima-ducc-web: affected <= 2.2.2; fixed in 3.0.0 ## Suggested inspection (read-only) - Maven org.apache.uima:uima-ducc-web: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.uima:uima-ducc-web. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vm59-329q-p468 (GitHub-reviewed advisory GHSA-vm59-329q-p468 lists affected ranges: Maven org.apache.uima:uima-ducc-web >=0 <=2.2.2) Commands are suggestions: review each one before running it.
Loading voting…