Skip to content

← Public intelligence

Maven package

org.apache.syncope:syncope-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

7 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Apache Syncope's AES encryption stores hard-coded passwords in internal database

    CVE-2025-65998 · GHSA-jqg8-m35q-jh7j

    Affected
    • Maven org.apache.syncope:syncope-core >= 4.0.0, < 4.0.3; < 3.0.15
    Fixed in
    3.0.154.0.3· Vendor fix available
    Issue
    Apache Syncope can be configured to store the user password values in the internal database with AES encryption, though this is not the default option. When AES is configured, the default key value, hard-coded in the source code, is always used. This allows a malicious attacker, once obtained access to the internal database content, to reconstruct the original cleartext password values. This is not affecting encrypted plain attributes, whose values are also stored using AES encryption. Users are recommended to upgrade to version 3.0.15 / 4.0.3, which fix this issue.

    Recommended action: Upgrade to 4.0.3 or 3.0.15 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8MavenPublished

    Expression Language Injection in Apache Syncope

    CVE-2020-1959 · GHSA-vjqw-r3ww-wj2w

    Affected
    • Maven org.apache.syncope:syncope-core < 2.1.6
    Fixed in
    2.1.6· Vendor fix available
    Issue
    A Server-Side Template Injection was identified in Apache Syncope prior to 2.1.6 enabling attackers to inject arbitrary Java EL expressions, leading to an unauthenticated Remote Code Execution (RCE) vulnerability. Apache Syncope uses Java Bean Validation (JSR 380) custom constraint validators. When building custom constraint violation error messages, they support different types of interpolation, including Java EL expressions. Therefore, if an attacker can inject arbitrary data in the error message template being passed, they will be able to run arbitrary Java code.

    Recommended action: Upgrade to 2.1.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.8MavenPublished

    Injection in Apache Syncope

    CVE-2020-1961 · GHSA-4w4p-xwrr-9crh

    Affected
    • Maven org.apache.syncope:syncope-core >= 2.0.0, < 2.0.15; >= 2.1.0, < 2.1.6
    Fixed in
    2.0.152.1.6· Vendor fix available
    Issue
    Vulnerability to Server-Side Template Injection on Mail templates for Apache Syncope 2.0.X releases prior to 2.0.15, 2.1.X releases prior to 2.1.6, enabling attackers to inject arbitrary JEXL expressions, leading to Remote Code Execution (RCE) was discovered.

    Recommended action: Upgrade to 2.1.6 or 2.0.15 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.2MavenPublished

    High severity vulnerability that affects org.apache.syncope:syncope-core

    CVE-2018-1321 · GHSA-xgc9-9w4v-h33h

    Affected
    • Maven org.apache.syncope:syncope-core < 1.2.11; >= 2.0.0, < 2.0.8
    Fixed in
    1.2.112.0.8· Vendor fix available
    Issue
    An administrator with report and template entitlements in Apache Syncope 1.2.x before 1.2.11 and 2.0.x before 2.0.8 can use XSL Transformations (XSLT) to perform malicious operations, including but not limited to file read, file write, and code execution.

    Recommended action: Upgrade to 2.0.8 or 1.2.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 4.9MavenPublished

    Exposure of Sensitive Information to an Unauthorized Actor in Apache syncope-cope

    CVE-2018-1322 · GHSA-v3vf-2r98-xw8w

    Affected
    • Maven org.apache.syncope:syncope-core < 1.2.11; >= 2.0.0, < 2.0.8
    Fixed in
    1.2.112.0.8· Vendor fix available
    Issue
    An administrator with user search entitlements in Apache Syncope 1.2.x before 1.2.11 and 2.0.x before 2.0.8 can recover sensitive security values using the fiql and orderby parameters.

    Recommended action: Upgrade to 2.0.8 or 1.2.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 5.4MavenPublished

    Improper Control of Interaction Frequency in Apache syncope-core

    CVE-2018-17184 · GHSA-9h9c-f287-c6vp

    Affected
    • Maven org.apache.syncope:syncope-core < 2.0.11; >= 2.1.0, < 2.1.2
    Fixed in
    2.1.22.0.11· Vendor fix available
    Issue
    A malicious user with enough administration entitlements can inject html-like elements containing JavaScript statements into Connector names, Report names, AnyTypeClass keys and Policy descriptions. When another user with enough administration entitlements edits one of the Entities above via Admin Console, the injected JavaScript code is executed.

    Recommended action: Upgrade to 2.1.2 or 2.0.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. High, CVSS 7.2MavenPublished

    Improper Restriction of XML External Entity Reference in org.apache.syncope:syncope-core

    CVE-2018-17186 · GHSA-qfjv-998w-q48f

    Affected
    • Maven org.apache.syncope:syncope-core < 2.0.11; >= 2.1.0, < 2.1.2
    Fixed in
    2.1.22.0.11· Vendor fix available
    Issue
    An administrator with workflow definition entitlements can use DTD to perform malicious operations, including but not limited to file read, file write, and code execution.

    Recommended action: Upgrade to 2.1.2 or 2.0.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →