Apache Syncope's AES encryption stores hard-coded passwords in internal database
CVE-2025-65998GHSA-jqg8-m35q-jh7j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.syncope:syncope-core 4.0.3, 3.0.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.syncope:syncope-core
- Affected
- >= 4.0.0, < 4.0.3< 3.0.15
- Fixed in
- 3.0.15, 4.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jqg8-m35q-jh7j lists affected ranges: Maven org.apache.syncope:syncope-core >=4.0.0 =0 <3.0.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2025-65998: 0.53% estimated exploitation activity in the next 30 days; percentile 44.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Syncope can be configured to store the user password values in the internal database with AES encryption, though this is not the default option. When AES is configured, the default key value, hard-coded in the source code, is always used. This allows a malicious attacker, once obtained access to the internal database content, to reconstruct the original cleartext password values. This is not affecting encrypted plain attributes, whose values are also stored using AES encryption. Users are recommended to upgrade to version 3.0.15 / 4.0.3, which fix this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jqg8-m35q-jh7j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-65998 Advisory: Apache Syncope's AES encryption stores hard-coded passwords in internal database IDs: CVE-2025-65998, GHSA-jqg8-m35q-jh7j Record: https://patchnext.com/advisories/cve-2025-65998 (revision 1, source checked 26 Oct 2026, 16:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.syncope:syncope-core 4.0.3, 3.0.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.syncope:syncope-core: affected >= 4.0.0, < 4.0.3; < 3.0.15; fixed in 3.0.15, 4.0.3 ## Suggested inspection (read-only) - Maven org.apache.syncope:syncope-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.syncope:syncope-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jqg8-m35q-jh7j (GitHub-reviewed advisory GHSA-jqg8-m35q-jh7j lists affected ranges: Maven org.apache.syncope:syncope-core >=4.0.0 =0 <3.0.15) Commands are suggestions: review each one before running it.
Loading voting…