Skip to content

← Public intelligence

Maven package

org.apache.solr:solr

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1MavenPublished

    Insecure Default Initialization of Resource vulnerability in Apache Solr

    CVE-2024-45217 · GHSA-h7w9-c5vx-x7j3

    Affected
    • Maven org.apache.solr:solr >= 6.6.0, < 8.11.4; >= 9.0.0, < 9.7.0
    Fixed in
    9.7.08.11.4· Vendor fix available
    Issue
    New ConfigSets that are created via a Restore command, which copy a configSet from the backup and give it a new name, are created without setting the "trusted" metadata. ConfigSets that do not contain the flag are trusted implicitly if the metadata is missing, therefore this leads to "trusted" ConfigSets that may not have been created with an Authenticated request. "trusted" ConfigSets are able to load custom code into classloaders, therefore the flag is supposed to only be set when the request that uploads the ConfigSet is Authenticated & Authorized. This issue affects Apache Solr: from 6.6.0 before 8.11.4, from 9.0.0 before 9.7.0. This issue does not affect Solr instances that are secured via Authentication/Authorization. Users are primarily recommended to use Authentication and Authorization when running Solr. However, upgrading to version 9.7.0, or 8.11.4 will mitigate this issue otherwise.

    Recommended action: Upgrade to 9.7.0 or 8.11.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.3MavenPublished

    Improper Authentication vulnerability in Apache Solr

    CVE-2024-45216 · GHSA-mjvf-4h88-6xm3

    Affected
    • Maven org.apache.solr:solr >= 5.3.0, < 8.11.4; >= 9.0.0, < 9.7.0
    Fixed in
    9.7.08.11.4· Vendor fix available
    Issue
    Solr instances using the PKIAuthenticationPlugin, which is enabled by default when Solr Authentication is used, are vulnerable to Authentication bypass. A fake ending at the end of any Solr API URL path, will allow requests to skip Authentication while maintaining the API contract with the original URL Path. This fake ending looks like an unprotected API path, however it is stripped off internally after authentication but before API routing. This issue affects Apache Solr: from 5.3.0 before 8.11.4, from 9.0.0 before 9.7.0. Users are recommended to upgrade to version 9.7.0, or 8.11.4, which fix the issue.

    Recommended action: Upgrade to 9.7.0 or 8.11.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedMavenPublished

    Improper Neutralization of Input During Web Page Generation in Apache Solr

    CVE-2014-3628 · GHSA-wgw2-gw4v-9w4j

    Affected
    • Maven org.apache.solr:solr >= 4.0.0, < 4.10.3
    Fixed in
    4.10.3· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in the Admin UI Plugin / Stats page in Apache Solr 4.x before 4.10.3 allows remote attackers to inject arbitrary web script or HTML via the fieldvaluecache object.

    Recommended action: Upgrade to 4.10.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 6.1MavenPublished

    Apache Solr Cross-site scripting Vulnerability

    CVE-2015-8796 · GHSA-4fxw-g29w-r8mx

    Affected
    • Maven org.apache.solr:solr < 5.3
    Fixed in
    5.3· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in webapp/web/js/scripts/schema-browser.js in the Admin UI in Apache Solr before 5.3 allows remote attackers to inject arbitrary web script or HTML via a crafted schema-browse URL.

    Recommended action: Upgrade to 5.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →