Improper Authentication vulnerability in Apache Solr
CVE-2024-45216GHSA-mjvf-4h88-6xm3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.solr:solr 9.7.0, 8.11.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.solr:solr
- Affected
- >= 5.3.0, < 8.11.4>= 9.0.0, < 9.7.0
- Fixed in
- 9.7.0, 8.11.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mjvf-4h88-6xm3 lists affected ranges: Maven org.apache.solr:solr >=5.3.0 =9.0.0 <9.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-45216: 92.75% estimated exploitation activity in the next 30 days; percentile 99.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Solr instances using the PKIAuthenticationPlugin, which is enabled by default when Solr Authentication is used, are vulnerable to Authentication bypass. A fake ending at the end of any Solr API URL path, will allow requests to skip Authentication while maintaining the API contract with the original URL Path. This fake ending looks like an unprotected API path, however it is stripped off internally after authentication but before API routing. This issue affects Apache Solr: from 5.3.0 before 8.11.4, from 9.0.0 before 9.7.0. Users are recommended to upgrade to version 9.7.0, or 8.11.4, which fix the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mjvf-4h88-6xm3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-45216 Advisory: Improper Authentication vulnerability in Apache Solr IDs: CVE-2024-45216, GHSA-mjvf-4h88-6xm3 Record: https://patchnext.com/advisories/cve-2024-45216 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.solr:solr 9.7.0, 8.11.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.solr:solr: affected >= 5.3.0, < 8.11.4; >= 9.0.0, < 9.7.0; fixed in 9.7.0, 8.11.4 ## Suggested inspection (read-only) - Maven org.apache.solr:solr: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.solr:solr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mjvf-4h88-6xm3 (GitHub-reviewed advisory GHSA-mjvf-4h88-6xm3 lists affected ranges: Maven org.apache.solr:solr >=5.3.0 =9.0.0 <9.7.0) Commands are suggestions: review each one before running it.
Loading voting…