Skip to content

← Public intelligence

Maven package

org.apache.rocketmq:rocketmq-namesrv

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8MavenPublished

    RocketMQ NameServer component Code Injection vulnerability

    CVE-2023-37582 · GHSA-gpq8-963w-8qc9

    Affected
    • Maven org.apache.rocketmq:rocketmq-namesrv < 4.9.7; >= 5.0.0, < 5.1.2
    Fixed in
    4.9.75.1.2· Vendor fix available
    Issue
    The RocketMQ NameServer component still has a remote command execution vulnerability as the CVE-2023-33246 issue was not completely fixed in version 5.1.1. When NameServer address are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function on the NameServer component to execute commands as the system users that RocketMQ is running as. It is recommended for users to upgrade their NameServer version to 5.1.2 or above for RocketMQ 5.x or 4.9.7 or above for RocketMQ 4.x to prevent these attacks.

    Recommended action: Upgrade to 5.1.2 or 4.9.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8Exploited · CISA KEVMavenPublished

    Apache RocketMQ may have remote code execution vulnerability when using update configuration function

    CVE-2023-33246 · GHSA-x3cq-8f32-5f63

    Affected
    • Maven org.apache.rocketmq:rocketmq-namesrv >= 4.0.0, < 4.9.6; >= 5.0.0, < 5.1.1
    Fixed in
    4.9.65.1.1· Vendor fix available
    Issue
    For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content. To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .

    Recommended action: Upgrade to 5.1.1 or 4.9.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)cisa.gov (2)Source checked Evidence →