Skip to content

← Actionable
Critical, CVSS 9.8Exploited · CISA KEV

Apache RocketMQ may have remote code execution vulnerability when using update configuration function

CVE-2023-33246GHSA-x3cq-8f32-5f63

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.rocketmq:rocketmq-controller 5.1.1; org.apache.rocketmq:rocketmq-broker 5.1.1; org.apache.rocketmq:rocketmq-namesrv 5.1.1, 4.9.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
EPSS
  • CVE-2023-33246: 96.57% estimated exploitation activity in the next 30 days; percentile 99.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content. To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x3cq-8f32-5f63

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-33246

Advisory: Apache RocketMQ may have remote code execution vulnerability when using update configuration function
IDs: CVE-2023-33246, GHSA-x3cq-8f32-5f63
Record: https://patchnext.com/advisories/cve-2023-33246 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: org.apache.rocketmq:rocketmq-controller 5.1.1; org.apache.rocketmq:rocketmq-broker 5.1.1; org.apache.rocketmq:rocketmq-namesrv 5.1.1, 4.9.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.rocketmq:rocketmq-controller: affected >= 5.0.0, < 5.1.1; fixed in 5.1.1
- Maven org.apache.rocketmq:rocketmq-broker: affected >= 5.0.0, < 5.1.1; fixed in 5.1.1
- Maven org.apache.rocketmq:rocketmq-namesrv: affected >= 4.0.0, < 4.9.6; >= 5.0.0, < 5.1.1; fixed in 4.9.6, 5.1.1

## Suggested inspection (read-only)
- Maven org.apache.rocketmq:rocketmq-controller: check the installed version with your package manager.
- Maven org.apache.rocketmq:rocketmq-broker: check the installed version with your package manager.
- Maven org.apache.rocketmq:rocketmq-namesrv: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.rocketmq:rocketmq-controller, org.apache.rocketmq:rocketmq-broker, org.apache.rocketmq:rocketmq-namesrv.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x3cq-8f32-5f63 (GitHub-reviewed advisory GHSA-x3cq-8f32-5f63 lists affected ranges: Maven org.apache.rocketmq:rocketmq-broker >=5.0.0 =4.0.0 =5.0.0 =5.0.0 <5.1.1)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2023-33246 to the Known Exploited Vulnerabilities catalog on 2023-09-06.)

Commands are suggestions: review each one before running it.

Loading voting…