Skip to content

← Public intelligence

Maven package

org.apache.qpid:apache-qpid-broker-j

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Improper Input Validation in Apache Qpid Broker-J

    CVE-2019-0200 · GHSA-c9h6-xhg9-xxrv

    Affected
    • Maven org.apache.qpid:apache-qpid-broker-j < 7.0.7; >= 7.1.0, <= 7.1.0
    Fixed in
    7.1.17.0.7· Vendor fix available
    Issue
    A Denial of Service vulnerability was found in Apache Qpid Broker-J versions 6.0.0-7.0.6 (inclusive) and 7.1.0 which allows an unauthenticated attacker to crash the broker instance by sending specially crafted commands using AMQP protocol versions below 1.0 (AMQP 0-8, 0-9, 0-91 and 0-10). Users of Apache Qpid Broker-J versions 6.0.0-7.0.6 (inclusive) and 7.1.0 utilizing AMQP protocols 0-8, 0-9, 0-91, 0-10 must upgrade to Qpid Broker-J versions 7.0.7 or 7.1.1 or later.

    Recommended action: Upgrade to 7.1.1 or 7.0.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.9MavenPublished

    Moderate severity vulnerability that affects org.apache.qpid:apache-qpid-broker-j

    CVE-2018-1298 · GHSA-6w3v-66mj-2qm6

    Affected
    • Maven org.apache.qpid:apache-qpid-broker-j >= 7.0.0, <= 7.0.0
    Fixed in
    7.0.1· Vendor fix available
    Issue
    A Denial of Service vulnerability was found in Apache Qpid Broker-J 7.0.0 in functionality for authentication of connections for AMQP protocols 0-8, 0-9, 0-91 and 0-10 when PLAIN or XOAUTH2 SASL mechanism is used. The vulnerability allows unauthenticated attacker to crash the broker instance. AMQP 1.0 and HTTP connections are not affected. An authentication of incoming AMQP connections in Apache Qpid Broker-J is performed by special entities called "Authentication Providers". Each Authentication Provider can support several SASL mechanisms which are offered to the connecting clients as part of SASL negotiation process. The client chooses the most appropriate SASL mechanism for authentication. Authentication Providers of following types supports PLAIN SASL mechanism: Plain, PlainPasswordFile, SimpleLDAP, Base64MD5PasswordFile, MD5, SCRAM-SHA-256, SCRAM-SHA-1. XOAUTH2 SASL mechanism is supported by Authentication Providers of type OAuth2. If an AMQP port is configured with any of these…

    Recommended action: Upgrade to 7.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5MavenPublished

    Denial of service vulnerability exists when .NET and .NET Core improperly process XML documents

    CVE-2018-8030 · GHSA-7xr3-rgwh-pw22

    Affected
    • Maven org.apache.qpid:apache-qpid-broker-j >= 7.0.0, < 7.1.0
    Fixed in
    7.1.0· Vendor fix available
    Issue
    A Denial of Service vulnerability was found in Apache Qpid Broker-J versions 7.x before 7.1.0 when AMQP protocols 0-8, 0-9 or 0-91 are used to publish messages with size greater than allowed maximum message size limit (100MB by default). The broker crashes due to the defect. AMQP protocols 0-10 and 1.0 are not affected.

    Recommended action: Upgrade to 7.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →