Skip to content

← Actionable
Medium, CVSS 5.9

Moderate severity vulnerability that affects org.apache.qpid:apache-qpid-broker-j

CVE-2018-1298GHSA-6w3v-66mj-2qm6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.qpid:apache-qpid-broker-j 7.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2018-1298: 2.33% estimated exploitation activity in the next 30 days; percentile 83.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A Denial of Service vulnerability was found in Apache Qpid Broker-J 7.0.0 in functionality for authentication of connections for AMQP protocols 0-8, 0-9, 0-91 and 0-10 when PLAIN or XOAUTH2 SASL mechanism is used. The vulnerability allows unauthenticated attacker to crash the broker instance. AMQP 1.0 and HTTP connections are not affected. An authentication of incoming AMQP connections in Apache Qpid Broker-J is performed by special entities called "Authentication Providers". Each Authentication Provider can support several SASL mechanisms which are offered to the connecting clients as part of SASL negotiation process. The client chooses the most appropriate SASL mechanism for authentication. Authentication Providers of following types supports PLAIN SASL mechanism: Plain, PlainPasswordFile, SimpleLDAP, Base64MD5PasswordFile, MD5, SCRAM-SHA-256, SCRAM-SHA-1. XOAUTH2 SASL mechanism is supported by Authentication Providers of type OAuth2. If an AMQP port is configured with any of these…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6w3v-66mj-2qm6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1298

Advisory: Moderate severity vulnerability that affects org.apache.qpid:apache-qpid-broker-j
IDs: CVE-2018-1298, GHSA-6w3v-66mj-2qm6
Record: https://patchnext.com/advisories/cve-2018-1298 (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.qpid:apache-qpid-broker-j 7.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.qpid:apache-qpid-broker-j: affected >= 7.0.0, <= 7.0.0; fixed in 7.0.1

## Suggested inspection (read-only)
- Maven org.apache.qpid:apache-qpid-broker-j: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.qpid:apache-qpid-broker-j.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6w3v-66mj-2qm6 (GitHub-reviewed advisory GHSA-6w3v-66mj-2qm6 lists affected ranges: Maven org.apache.qpid:apache-qpid-broker-j >=7.0.0 <=7.0.0)

Commands are suggestions: review each one before running it.

Loading voting…