Skip to content

← Public intelligence

Maven package

org.apache.pulsar:pulsar-io-kafka-connect-adaptor

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.3MavenPublished

    Apache Pulsar Kafka Connector Logs Sensitive Information in Application Logs

    CVE-2025-30677 · GHSA-rcqj-3fmp-5cqx

    Affected
    • Maven org.apache.pulsar:pulsar-io-kafka-connect-adaptor < 3.0.11; >= 3.3.0, < 3.3.6; >= 4.0.0, < 4.0.4
    Fixed in
    3.0.113.3.64.0.4· Vendor fix available
    Issue
    Apache Pulsar contains multiple connectors for integrating with Apache Kafka. The Pulsar IO Apache Kafka Source Connector, Sink Connector, and Kafka Connect Adaptor Sink Connector log sensitive configuration properties in plain text in application logs. This vulnerability can lead to unintended exposure of credentials in log files, potentially allowing attackers with access to these logs to obtain Apache Kafka credentials. The vulnerability's impact is limited by the fact that an attacker would need access to the application logs to exploit this issue. This issue affects Apache Pulsar IO's Apache Kafka connectors in all versions before 3.0.11, 3.3.6, and 4.0.4. 3.0.x version users should upgrade to at least 3.0.11. 3.3.x version users should upgrade to at least 3.3.6. 4.0.x version users should upgrade to at least 4.0.4. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

    Recommended action: Upgrade to 4.0.4, 3.3.6 or 3.0.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →