Skip to content

← Actionable
Medium, CVSS 6.3

Apache Pulsar Kafka Connector Logs Sensitive Information in Application Logs

CVE-2025-30677GHSA-rcqj-3fmp-5cqx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.pulsar:pulsar-io-kafka 4.0.4, 3.3.6, 3.0.11; org.apache.pulsar:pulsar-io-kafka-connect-adaptor 4.0.4, 3.3.6, 3.0.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-rcqj-3fmp-5cqx lists affected ranges: Maven org.apache.pulsar:pulsar-io-kafka-connect-adaptor >=0 =3.3.0 =4.0.0 =0 =3.3.0 =4.0.0 <4.0.4

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2025-30677: 0.74% estimated exploitation activity in the next 30 days; percentile 54.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Pulsar contains multiple connectors for integrating with Apache Kafka. The Pulsar IO Apache Kafka Source Connector, Sink Connector, and Kafka Connect Adaptor Sink Connector log sensitive configuration properties in plain text in application logs. This vulnerability can lead to unintended exposure of credentials in log files, potentially allowing attackers with access to these logs to obtain Apache Kafka credentials. The vulnerability's impact is limited by the fact that an attacker would need access to the application logs to exploit this issue. This issue affects Apache Pulsar IO's Apache Kafka connectors in all versions before 3.0.11, 3.3.6, and 4.0.4. 3.0.x version users should upgrade to at least 3.0.11. 3.3.x version users should upgrade to at least 3.3.6. 4.0.x version users should upgrade to at least 4.0.4. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rcqj-3fmp-5cqx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-30677

Advisory: Apache Pulsar Kafka Connector Logs Sensitive Information in Application Logs
IDs: CVE-2025-30677, GHSA-rcqj-3fmp-5cqx
Record: https://patchnext.com/advisories/cve-2025-30677 (revision 1, source checked 26 Oct 2026, 16:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.pulsar:pulsar-io-kafka 4.0.4, 3.3.6, 3.0.11; org.apache.pulsar:pulsar-io-kafka-connect-adaptor 4.0.4, 3.3.6, 3.0.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.pulsar:pulsar-io-kafka: affected < 3.0.11; >= 3.3.0, < 3.3.6; >= 4.0.0, < 4.0.4; fixed in 3.0.11, 3.3.6, 4.0.4
- Maven org.apache.pulsar:pulsar-io-kafka-connect-adaptor: affected < 3.0.11; >= 3.3.0, < 3.3.6; >= 4.0.0, < 4.0.4; fixed in 3.0.11, 3.3.6, 4.0.4

## Suggested inspection (read-only)
- Maven org.apache.pulsar:pulsar-io-kafka: check the installed version with your package manager.
- Maven org.apache.pulsar:pulsar-io-kafka-connect-adaptor: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.pulsar:pulsar-io-kafka, org.apache.pulsar:pulsar-io-kafka-connect-adaptor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rcqj-3fmp-5cqx (GitHub-reviewed advisory GHSA-rcqj-3fmp-5cqx lists affected ranges: Maven org.apache.pulsar:pulsar-io-kafka-connect-adaptor >=0 =3.3.0 =4.0.0 =0 =3.3.0 =4.0.0 <4.0.4)

Commands are suggestions: review each one before running it.

Loading voting…