Skip to content

← Public intelligence

Maven package

org.apache.pulsar:pulsar-broker-auth-sasl

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.4MavenPublished

    Apache Pulsar SASL Authentication Provider observable timing discrepancy vulnerability

    CVE-2023-51437 · GHSA-c57v-4vg5-cm2x

    Affected
    • Maven org.apache.pulsar:pulsar-broker-auth-sasl < 2.11.3; >= 3.0.0, < 3.0.2; >= 3.1.0, < 3.1.1
    Fixed in
    3.0.23.1.12.11.3· Vendor fix available
    Issue
    Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the saslJaasServerRoleTokenSignerSecretPath file. Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker. 2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions. For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .

    Recommended action: Upgrade to 3.1.1, 3.0.2 or 2.11.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →