Apache Pulsar SASL Authentication Provider observable timing discrepancy vulnerability
CVE-2023-51437GHSA-c57v-4vg5-cm2x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.pulsar:pulsar-broker-auth-sasl 3.1.1, 3.0.2, 2.11.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.pulsar:pulsar-broker-auth-sasl
- Affected
- < 2.11.3>= 3.0.0, < 3.0.2>= 3.1.0, < 3.1.1
- Fixed in
- 3.0.2, 3.1.1, 2.11.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c57v-4vg5-cm2x lists affected ranges: Maven org.apache.pulsar:pulsar-broker-auth-sasl >=0 =3.0.0 =3.1.0 <3.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2023-51437: 0.76% estimated exploitation activity in the next 30 days; percentile 55.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the saslJaasServerRoleTokenSignerSecretPath file. Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker. 2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions. For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c57v-4vg5-cm2x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-51437 Advisory: Apache Pulsar SASL Authentication Provider observable timing discrepancy vulnerability IDs: CVE-2023-51437, GHSA-c57v-4vg5-cm2x Record: https://patchnext.com/advisories/cve-2023-51437 (revision 1, source checked 26 Oct 2026, 16:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.pulsar:pulsar-broker-auth-sasl 3.1.1, 3.0.2, 2.11.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.pulsar:pulsar-broker-auth-sasl: affected < 2.11.3; >= 3.0.0, < 3.0.2; >= 3.1.0, < 3.1.1; fixed in 3.0.2, 3.1.1, 2.11.3 ## Suggested inspection (read-only) - Maven org.apache.pulsar:pulsar-broker-auth-sasl: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.pulsar:pulsar-broker-auth-sasl. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c57v-4vg5-cm2x (GitHub-reviewed advisory GHSA-c57v-4vg5-cm2x lists affected ranges: Maven org.apache.pulsar:pulsar-broker-auth-sasl >=0 =3.0.0 =3.1.0 <3.1.1) Commands are suggestions: review each one before running it.
Loading voting…