Skip to content

← Public intelligence

Maven package

org.apache.mesos:mesos

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Crash when decoding malformed HTTP requests or malformed JSON payload

    CVE-2018-1330 · GHSA-95q3-pppp-r683

    Affected
    • Maven org.apache.mesos:mesos >= 1.4.0, < 1.6.0
    Fixed in
    1.6.0· Vendor fix available
    Issue
    When parsing a malformed JSON payload, libprocess in Apache Mesos versions 1.4.0 to 1.5.0 might crash due to an uncaught exception. Parsing chunked HTTP requests with trailers can lead to a libprocess crash too because of the mistakenly planted assertion. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.

    Recommended action: Upgrade to 1.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5MavenPublished

    Use after free in Apache Mesos

    CVE-2017-9790 · GHSA-vpcv-78cp-whr3

    Affected
    • Maven org.apache.mesos:mesos < 1.1.3; >= 1.2.0, < 1.2.2; >= 1.3.0, < 1.3.1
    Fixed in
    1.2.21.3.11.1.3· Vendor fix available
    Issue
    When handling a libprocess message wrapped in an HTTP request, libprocess in Apache Mesos before 1.1.3, 1.2.x before 1.2.2, 1.3.x before 1.3.1, and 1.4.0-dev crashes if the request path is empty, because the parser assumes the request path always starts with '/'. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.

    Recommended action: Upgrade to 1.3.1, 1.2.2 or 1.1.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5MavenPublished

    Denial of service in Apache Mesos

    CVE-2017-7687 · GHSA-x869-784m-jmj2

    Affected
    • Maven org.apache.mesos:mesos < 1.1.3; >= 1.2.0, < 1.2.2; >= 1.3.0, < 1.3.1
    Fixed in
    1.2.21.3.11.1.3· Vendor fix available
    Issue
    When handling a decoding failure for a malformed URL path of an HTTP request, libprocess in Apache Mesos might crash because the code accidentally calls inappropriate function. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.

    Recommended action: Upgrade to 1.3.1, 1.2.2 or 1.1.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.8MavenPublished

    Docker image code execution with Apache Mesos

    CVE-2019-0204 · GHSA-32w9-2qpc-5f9v

    Affected
    • Maven org.apache.mesos:mesos < 1.4.3; >= 1.5.0, < 1.5.3; >= 1.6.0, < 1.6.2; >= 1.7.0, < 1.7.2
    Fixed in
    1.7.21.5.31.4.31.6.2· Vendor fix available
    Issue
    A specifically crafted Docker image running under the root user can overwrite the init helper binary of the container runtime and/or the command executor in Apache Mesos versions pre-1.4.x, 1.4.0 to 1.4.2, 1.5.0 to 1.5.2, 1.6.0 to 1.6.1, and 1.7.0 to 1.7.1. A malicious actor can therefore gain root-level code execution on the host.

    Recommended action: Upgrade to 1.7.2, 1.6.2, 1.5.3 or 1.4.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 7.5MavenPublished

    Stack Overflow in Apache Mesos

    CVE-2018-11793 · GHSA-p2xq-vcm7-xjj6

    Affected
    • Maven org.apache.mesos:mesos < 1.4.3; >= 1.5.0, < 1.5.2; >= 1.6.0, < 1.6.2; >= 1.7.0, <= 1.7.0
    Fixed in
    1.5.21.7.11.4.31.6.2· Vendor fix available
    Issue
    When parsing a JSON payload with deeply nested JSON structures, the parser in Apache Mesos versions pre-1.4.x, 1.4.0 to 1.4.2, 1.5.0 to 1.5.1, 1.6.0 to 1.6.1, and 1.7.0 might overflow the stack due to unbounded recursion. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.

    Recommended action: Upgrade to 1.7.1, 1.6.2, 1.5.2 or 1.4.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 5.9MavenPublished

    Moderate severity vulnerability that affects org.apache.mesos:mesos

    CVE-2018-8023 · GHSA-c8cc-p3j7-4c7f

    Affected
    • Maven org.apache.mesos:mesos < 1.4.2; >= 1.5.0, < 1.5.2; >= 1.6.0, < 1.6.1
    Fixed in
    1.4.21.5.21.6.1· Vendor fix available
    Issue
    Apache Mesos can be configured to require authentication to call the Executor HTTP API using JSON Web Token (JWT). In Apache Mesos versions pre-1.4.2, 1.5.0, 1.5.1, 1.6.0 the comparison of the generated HMAC value against the provided signature in the JWT implementation used is vulnerable to a timing attack because instead of a constant-time string comparison routine a standard == operator has been used. A malicious actor can therefore abuse the timing difference of when the JWT validation function returns to reveal the correct HMAC value.

    Recommended action: Upgrade to 1.6.1, 1.5.2 or 1.4.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →