Skip to content

← Actionable
High, CVSS 7.8

Docker image code execution with Apache Mesos

CVE-2019-0204GHSA-32w9-2qpc-5f9v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.mesos:mesos 1.7.2, 1.6.2, 1.5.3, 1.4.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.mesos:mesos

    Affected
    < 1.4.3>= 1.5.0, < 1.5.3>= 1.6.0, < 1.6.2>= 1.7.0, < 1.7.2
    Fixed in
    1.7.2, 1.5.3, 1.4.3, 1.6.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-0204: 2.71% estimated exploitation activity in the next 30 days; percentile 86.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A specifically crafted Docker image running under the root user can overwrite the init helper binary of the container runtime and/or the command executor in Apache Mesos versions pre-1.4.x, 1.4.0 to 1.4.2, 1.5.0 to 1.5.2, 1.6.0 to 1.6.1, and 1.7.0 to 1.7.1. A malicious actor can therefore gain root-level code execution on the host.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-32w9-2qpc-5f9v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-0204

Advisory: Docker image code execution with Apache Mesos
IDs: CVE-2019-0204, GHSA-32w9-2qpc-5f9v
Record: https://patchnext.com/advisories/cve-2019-0204 (revision 1, source checked 26 Oct 2026, 16:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.mesos:mesos 1.7.2, 1.6.2, 1.5.3, 1.4.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.mesos:mesos: affected < 1.4.3; >= 1.5.0, < 1.5.3; >= 1.6.0, < 1.6.2; >= 1.7.0, < 1.7.2; fixed in 1.7.2, 1.5.3, 1.4.3, 1.6.2

## Suggested inspection (read-only)
- Maven org.apache.mesos:mesos: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.mesos:mesos.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-32w9-2qpc-5f9v (GitHub-reviewed advisory GHSA-32w9-2qpc-5f9v lists affected ranges: Maven org.apache.mesos:mesos >=0 =1.5.0 =1.6.0 =1.7.0 <1.7.2)

Commands are suggestions: review each one before running it.

Loading voting…