Skip to content

← Public intelligence

Maven package

org.apache.livy:livy-server

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.3MavenPublished

    Apache Livy: Unauthorized directory access

    CVE-2025-66249 · GHSA-h84f-4ff9-8hc3

    Affected
    • Maven org.apache.livy:livy-server >= 0.3.0-incubating, < 0.9.0-incubating
    Fixed in
    0.9.0-incubating· Vendor fix available
    Issue
    Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Livy. This issue affects Apache Livy: from 0.3.0 before 0.9.0. The vulnerability can only be exploited with non-default Apache Livy Server settings. If the configuration value "livy.file.local-dir-whitelist" is set to a non-default value, the directory checking can be bypassed. Users are recommended to upgrade to version 0.9.0, which fixes the issue.

    Recommended action: Upgrade to 0.9.0-incubating (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.3MavenPublished

    Apache Livy: Restrict file access

    CVE-2025-60012 · GHSA-hm8x-rpgg-7855

    Affected
    • Maven org.apache.livy:livy-server >= 0.7.0-incubating, < 0.9.0-incubating
    Fixed in
    0.9.0-incubating· Vendor fix available
    Issue
    Malicious configuration can lead to unauthorized file access in Apache Livy. This issue affects Apache Livy 0.7.0 and 0.8.0 when connecting to Apache Spark 3.1 or later. A request that includes a Spark configuration value supported from Apache Spark version 3.1 can lead to users gaining access to files they do not have permissions to. For the vulnerability to be exploitable, the user needs to have access to Apache Livy's REST or JDBC interface and be able to send requests with arbitrary Spark configuration values. Users are recommended to upgrade to version 0.9.0 or later, which fixes the issue.

    Recommended action: Upgrade to 0.9.0-incubating (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.4MavenPublished

    Apache Livy Cross-site scripting (XSS) in session names

    CVE-2021-26544 · GHSA-74qp-233x-p5j8

    Affected
    • Maven org.apache.livy:livy-server >= 0.7.0-incubating, <= 0.7.0-incubating
    Fixed in
    0.7.1-incubating· Vendor fix available
    Issue
    Livy server version 0.7.0-incubating (only) is vulnerable to a cross site scripting issue in the session name. A malicious user could use this flaw to access logs and results of other users' sessions and run jobs with their privileges. This issue is fixed in Livy 0.7.1-incubating.

    Recommended action: Upgrade to 0.7.1-incubating (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →