Apache Livy Cross-site scripting (XSS) in session names
CVE-2021-26544GHSA-74qp-233x-p5j8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.livy:livy-server 0.7.1-incubating), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.livy:livy-server
- Affected
- >= 0.7.0-incubating, <= 0.7.0-incubating
- Fixed in
- 0.7.1-incubating
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-74qp-233x-p5j8 lists affected ranges: Maven org.apache.livy:livy-server >=0.7.0-incubating <=0.7.0-incubating
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-26544: 2.82% estimated exploitation activity in the next 30 days; percentile 86.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Livy server version 0.7.0-incubating (only) is vulnerable to a cross site scripting issue in the session name. A malicious user could use this flaw to access logs and results of other users' sessions and run jobs with their privileges. This issue is fixed in Livy 0.7.1-incubating.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-74qp-233x-p5j8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-26544 Advisory: Apache Livy Cross-site scripting (XSS) in session names IDs: CVE-2021-26544, GHSA-74qp-233x-p5j8 Record: https://patchnext.com/advisories/cve-2021-26544 (revision 1, source checked 26 Oct 2026, 16:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.livy:livy-server 0.7.1-incubating. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.livy:livy-server: affected >= 0.7.0-incubating, <= 0.7.0-incubating; fixed in 0.7.1-incubating ## Suggested inspection (read-only) - Maven org.apache.livy:livy-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.livy:livy-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-74qp-233x-p5j8 (GitHub-reviewed advisory GHSA-74qp-233x-p5j8 lists affected ranges: Maven org.apache.livy:livy-server >=0.7.0-incubating <=0.7.0-incubating) Commands are suggestions: review each one before running it.
Loading voting…