Skip to content

← Public intelligence

Maven package

org.apache.kafka:kafka

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Apache Kafka vulnerability can lead to brokers hitting OutOfMemoryException, causing Denial of Service

    CVE-2022-34917 · GHSA-c9h3-c6qj-hh7q

    Affected
    • Maven org.apache.kafka:kafka >= 2.8.0, < 2.8.2; >= 3.0.0, < 3.0.2; >= 3.1.0, < 3.1.2; >= 3.2.0, < 3.2.3
    Fixed in
    3.0.23.1.23.2.32.8.2· Vendor fix available
    Issue
    A security vulnerability has been identified in Apache Kafka. It affects all releases since 2.8.0. The vulnerability allows malicious unauthenticated clients to allocate large amounts of memory on brokers. This can lead to brokers hitting OutOfMemoryException and causing denial of service. Example scenarios: - Kafka cluster without authentication: Any clients able to establish a network connection to a broker can trigger the issue. - Kafka cluster with SASL authentication: Any clients able to establish a network connection to a broker, without the need for valid SASL credentials, can trigger the issue. - Kafka cluster with TLS authentication: Only clients able to successfully authenticate via TLS can trigger the issue. We advise the users to upgrade the Kafka installations to one of the 3.2.3, 3.1.2, 3.0.2, 2.8.2 versions.

    Recommended action: Upgrade to 3.2.3, 3.1.2, 3.0.2 or 2.8.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.8MavenPublished

    Improper Input Validation in Apache Kafka

    CVE-2018-17196 · GHSA-47w3-66wq-cpxg

    Affected
    • Maven org.apache.kafka:kafka >= 0.11.0.0, <= 2.1.0
    Fixed in
    2.1.1· Vendor fix available
    Issue
    In Apache Kafka versions between 0.11.0.0 and 2.1.0, it is possible to manually craft a Produce request which bypasses transaction/idempotent ACL validation. Only authenticated clients with Write permission on the respective topics are able to exploit this vulnerability. Users should upgrade to 2.1.1 or later where this vulnerability has been fixed.

    Recommended action: Upgrade to 2.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.4MavenPublished

    Improper Control of Generation of Code in Apache Kafka

    CVE-2018-1288 · GHSA-gh27-38p5-mrxc

    Affected
    • Maven org.apache.kafka:kafka >= 0.9.0.0, <= 0.10.2.1; >= 0.11.0.0, <= 0.11.0.2; >= 1.0.0, <= 1.0.0
    Fixed in
    0.11.0.30.10.2.21.0.1· Vendor fix available
    Issue
    In Apache Kafka 0.9.0.0 to 0.9.0.1, 0.10.0.0 to 0.10.2.1, 0.11.0.0 to 0.11.0.2, and 1.0.0, authenticated Kafka users may perform action reserved for the Broker via a manually created fetch request interfering with data replication, resulting in data loss.

    Recommended action: Upgrade to 1.0.1, 0.11.0.3 or 0.10.2.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5MavenPublished

    Exposure of Sensitive Information to an Unauthorized Actor in Apache Kafka

    CVE-2019-12399 · GHSA-6jmf-mxwf-r3jc

    Affected
    • Maven org.apache.kafka:kafka >= 2.0.0, <= 2.0.1; >= 2.1.0, <= 2.1.1; >= 2.2.0, <= 2.2.1; >= 2.3.0, <= 2.3.0
    Fixed in
    2.1.22.2.22.0.22.3.1· Vendor fix available
    Issue
    When Connect workers in Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, or 2.3.0 are configured with one or more config providers, and a connector is created/updated on that Connect cluster to use an externalized secret variable in a substring of a connector configuration property value, then any client can issue a request to the same Connect cluster to obtain the connector's task configuration and the response will contain the plaintext secret rather than the externalized secrets variables.

    Recommended action: Upgrade to 2.3.1, 2.2.2, 2.1.2 or 2.0.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →