Skip to content

← Actionable
Medium, CVSS 5.4

Improper Control of Generation of Code in Apache Kafka

CVE-2018-1288GHSA-gh27-38p5-mrxc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.kafka:kafka 1.0.1, 0.11.0.3, 0.10.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.kafka:kafka

    Affected
    >= 0.9.0.0, <= 0.10.2.1>= 0.11.0.0, <= 0.11.0.2>= 1.0.0, <= 1.0.0
    Fixed in
    0.11.0.3, 0.10.2.2, 1.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
EPSS
  • CVE-2018-1288: 4.80% estimated exploitation activity in the next 30 days; percentile 91.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Apache Kafka 0.9.0.0 to 0.9.0.1, 0.10.0.0 to 0.10.2.1, 0.11.0.0 to 0.11.0.2, and 1.0.0, authenticated Kafka users may perform action reserved for the Broker via a manually created fetch request interfering with data replication, resulting in data loss.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gh27-38p5-mrxc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1288

Advisory: Improper Control of Generation of Code in Apache Kafka
IDs: CVE-2018-1288, GHSA-gh27-38p5-mrxc
Record: https://patchnext.com/advisories/cve-2018-1288 (revision 1, source checked 26 Oct 2026, 16:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.kafka:kafka 1.0.1, 0.11.0.3, 0.10.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.kafka:kafka: affected >= 0.9.0.0, <= 0.10.2.1; >= 0.11.0.0, <= 0.11.0.2; >= 1.0.0, <= 1.0.0; fixed in 0.11.0.3, 0.10.2.2, 1.0.1

## Suggested inspection (read-only)
- Maven org.apache.kafka:kafka: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.kafka:kafka.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gh27-38p5-mrxc (GitHub-reviewed advisory GHSA-gh27-38p5-mrxc lists affected ranges: Maven org.apache.kafka:kafka >=0.9.0.0 =0.11.0.0 =1.0.0 <=1.0.0)

Commands are suggestions: review each one before running it.

Loading voting…