High, CVSS 8.8MavenPublished
Apache Jackrabbit vulnerable to blind XXE attack due to insecure document build
CVE-2025-53689 · GHSA-44c3-38h8-9fh9
- Affected
- Maven org.apache.jackrabbit:jackrabbit-spi-commons >= 2.20.0, < 2.20.17; >= 2.22.0, < 2.22.1; >= 2.23.0-beta, < 2.23.2-beta
- Fixed in
- 2.22.12.20.172.23.2-beta· Vendor fix available
- Issue
- Blind XXE vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges. Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.
Recommended action: Upgrade to 2.23.2-beta (pre-release), 2.22.1 or 2.20.17 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.