Skip to content

← Actionable
High, CVSS 8.8

Apache Jackrabbit vulnerable to blind XXE attack due to insecure document build

CVE-2025-53689GHSA-44c3-38h8-9fh9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.jackrabbit:jackrabbit-core 2.23.2-beta, 2.22.1, 2.20.17; org.apache.jackrabbit:jackrabbit-spi-commons 2.23.2-beta, 2.22.1, 2.20.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-44c3-38h8-9fh9 lists affected ranges: Maven org.apache.jackrabbit:jackrabbit-spi-commons >=2.20.0 =2.22.0 =2.23.0-beta =2.23.0-beta =2.20.0 =2.22.0 <2.22.1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-53689: 0.54% estimated exploitation activity in the next 30 days; percentile 45.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Blind XXE vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges. Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-44c3-38h8-9fh9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-53689

Advisory: Apache Jackrabbit vulnerable to blind XXE attack due to insecure document build
IDs: CVE-2025-53689, GHSA-44c3-38h8-9fh9
Record: https://patchnext.com/advisories/cve-2025-53689 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.jackrabbit:jackrabbit-core 2.23.2-beta, 2.22.1, 2.20.17; org.apache.jackrabbit:jackrabbit-spi-commons 2.23.2-beta, 2.22.1, 2.20.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.jackrabbit:jackrabbit-core: affected >= 2.23.0-beta, < 2.23.2-beta; >= 2.20.0, < 2.20.17; >= 2.22.0, < 2.22.1; fixed in 2.22.1, 2.20.17, 2.23.2-beta
- Maven org.apache.jackrabbit:jackrabbit-spi-commons: affected >= 2.20.0, < 2.20.17; >= 2.22.0, < 2.22.1; >= 2.23.0-beta, < 2.23.2-beta; fixed in 2.22.1, 2.20.17, 2.23.2-beta

## Suggested inspection (read-only)
- Maven org.apache.jackrabbit:jackrabbit-core: check the installed version with your package manager.
- Maven org.apache.jackrabbit:jackrabbit-spi-commons: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.jackrabbit:jackrabbit-core, org.apache.jackrabbit:jackrabbit-spi-commons.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-44c3-38h8-9fh9 (GitHub-reviewed advisory GHSA-44c3-38h8-9fh9 lists affected ranges: Maven org.apache.jackrabbit:jackrabbit-spi-commons >=2.20.0 =2.22.0 =2.23.0-beta =2.23.0-beta =2.20.0 =2.22.0 <2.22.1)

Commands are suggestions: review each one before running it.

Loading voting…