Skip to content

← Public intelligence

Maven package

org.apache.hive:hive-service

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

7 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.3MavenPublished

    Improper Authentication in org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service

    CVE-2015-1772 · GHSA-5gvm-hrw5-h6xf

    Affected
    • Maven org.apache.hive:hive-service >= 1.0.0, <= 1.0.0; >= 1.1.0, <= 1.1.0
    Fixed in
    1.1.11.0.1· Vendor fix available
    Issue
    The LDAP implementation in HiveServer2 in Apache Hive before 1.0.1 and 1.1.x before 1.1.1, as used in IBM InfoSphere BigInsights 3.0, 3.0.0.1, and 3.0.0.2 and other products, mishandles simple unauthenticated and anonymous bind configurations, which allows remote attackers to bypass authentication via a crafted LDAP request.

    Recommended action: Upgrade to 1.1.1 or 1.0.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5MavenPublished

    org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service vulnerable to Improper Certificate Validation

    CVE-2016-3083 · GHSA-gf2v-9hp6-44qg

    Affected
    • Maven org.apache.hive:hive-service < 1.2.2; >= 2.0.0, <= 2.0.0
    Fixed in
    2.0.11.2.2· Vendor fix available
    Issue
    Apache Hive (JDBC + HiveServer2) implements SSL for plain TCP and HTTP connections (it supports both transport modes). While validating the server's certificate during the connection setup, the client in Apache Hive before 1.2.2 and 2.0.x before 2.0.1 doesn't seem to be verifying the common name attribute of the certificate. In this way, if a JDBC client sends an SSL request to server abc.com, and the server responds with a valid certificate (certified by CA) but issued to xyz.com, the client will accept that as a valid certificate and the SSL handshake will go through.

    Recommended action: Upgrade to 2.0.1 or 1.2.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 4.3MavenPublished

    Moderate severity vulnerability that affects org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service

    CVE-2017-12625 · GHSA-2g9q-chq2-w8qw

    Affected
    • Maven org.apache.hive:hive-service >= 2.1.0, < 2.1.2; >= 2.2.0, <= 2.2.0; >= 2.3.0, <= 2.3.0
    Fixed in
    2.1.22.3.12.2.1· Vendor fix available
    Issue
    Apache Hive 2.1.x before 2.1.2, 2.2.x before 2.2.1, and 2.3.x before 2.3.1 expose an interface through which masking policies can be defined on tables or views, e.g., using Apache Ranger. When a view is created over a given table, the policy enforcement does not happen correctly on the table for masked columns.

    Recommended action: Upgrade to 2.3.1, 2.2.1 or 2.1.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Low, CVSS 3.7MavenPublished

    Exposure of Sensitive Information to an Unauthorized Actor in Apache hive

    CVE-2018-1284 · GHSA-rxmr-c9jm-7mm8

    Affected
    • Maven org.apache.hive:hive-service >= 0.6.0, < 2.3.3
    Fixed in
    2.3.3· Vendor fix available
    Issue
    In Apache Hive 0.6.0 to 2.3.2, malicious user might use any xpath UDFs (xpath/xpathstring/xpathboolean/xpathnumber/xpathdouble/xpathfloat/xpathlong/xpathint/xpathshort) to expose the content of a file on the machine running HiveServer2 owned by HiveServer2 user (usually hive) if hive.server2.enable.doAs=false.

    Recommended action: Upgrade to 2.3.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Low, CVSS 3.7MavenPublished

    Incorrect Permission Assignment for Critical Resource in Apache hive

    CVE-2018-1315 · GHSA-p639-xxv5-j383

    Affected
    • Maven org.apache.hive:hive-service >= 2.1.0, < 2.3.3
    Fixed in
    2.3.3· Vendor fix available
    Issue
    In Apache Hive 2.1.0 to 2.3.2, when 'COPY FROM FTP' statement is run using HPL/SQL extension to Hive, a compromised/malicious FTP server can cause the file to be written to an arbitrary location on the cluster where the command is run from. This is because FTP client code in HPL/SQL does not verify the destination location of the downloaded file. This does not affect hive cli user and hiveserver2 user as hplsql is a separate command line script and needs to be invoked differently.

    Recommended action: Upgrade to 2.3.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. High, CVSS 8.3MavenPublished

    High severity vulnerability that affects org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service

    CVE-2015-7521 · GHSA-83r3-c79w-f6wc

    Affected
    • Maven org.apache.hive:hive-service >= 1.0.0, < 1.2.2
    Fixed in
    1.2.2· Vendor fix available
    Issue
    The authorization framework in Apache Hive 1.0.0, 1.0.1, 1.1.0, 1.1.1, 1.2.0 and 1.2.1, on clusters protected by Ranger and SqlStdHiveAuthorization, allows attackers to bypass intended parent table access restrictions via unspecified partition-level operations.

    Recommended action: Upgrade to 1.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. UnratedMavenPublished

    Low severity vulnerability that affects org.apache.hive:hive-exec, org.apache.hive:hive, and org.apache.hive:hive-service

    CVE-2014-0228 · GHSA-w4x9-4f5x-8jj8

    Affected
    • Maven org.apache.hive:hive-service < 0.13.1
    Fixed in
    0.13.1· Vendor fix available
    Issue
    Apache Hive before 0.13.1, when in SQL standards based authorization mode, does not properly check the file permissions for (1) import and (2) export statements, which allows remote authenticated users to obtain sensitive information via a crafted URI.

    Recommended action: Upgrade to 0.13.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →