org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service vulnerable to Improper Certificate Validation
CVE-2016-3083GHSA-gf2v-9hp6-44qg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.hive:hive-exec 2.0.1, 1.2.2; org.apache.hive:hive-service 2.0.1, 1.2.2; org.apache.hive:hive 2.0.1, 1.2.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.hive:hive-exec
- Affected
- < 1.2.2>= 2.0.0, <= 2.0.0
- Fixed in
- 2.0.1, 1.2.2
Maven org.apache.hive:hive-service
- Affected
- < 1.2.2>= 2.0.0, <= 2.0.0
- Fixed in
- 2.0.1, 1.2.2
Maven org.apache.hive:hive
- Affected
- < 1.2.2>= 2.0.0, <= 2.0.0
- Fixed in
- 2.0.1, 1.2.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gf2v-9hp6-44qg lists affected ranges: Maven org.apache.hive:hive >=0 =2.0.0 =0 =2.0.0 =0 =2.0.0 <=2.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2016-3083: 1.01% estimated exploitation activity in the next 30 days; percentile 63.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Hive (JDBC + HiveServer2) implements SSL for plain TCP and HTTP connections (it supports both transport modes). While validating the server's certificate during the connection setup, the client in Apache Hive before 1.2.2 and 2.0.x before 2.0.1 doesn't seem to be verifying the common name attribute of the certificate. In this way, if a JDBC client sends an SSL request to server abc.com, and the server responds with a valid certificate (certified by CA) but issued to xyz.com, the client will accept that as a valid certificate and the SSL handshake will go through.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gf2v-9hp6-44qg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-3083 Advisory: org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service vulnerable to Improper Certificate Validation IDs: CVE-2016-3083, GHSA-gf2v-9hp6-44qg Record: https://patchnext.com/advisories/cve-2016-3083 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.hive:hive-exec 2.0.1, 1.2.2; org.apache.hive:hive-service 2.0.1, 1.2.2; org.apache.hive:hive 2.0.1, 1.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.hive:hive-exec: affected < 1.2.2; >= 2.0.0, <= 2.0.0; fixed in 2.0.1, 1.2.2 - Maven org.apache.hive:hive-service: affected < 1.2.2; >= 2.0.0, <= 2.0.0; fixed in 2.0.1, 1.2.2 - Maven org.apache.hive:hive: affected < 1.2.2; >= 2.0.0, <= 2.0.0; fixed in 2.0.1, 1.2.2 ## Suggested inspection (read-only) - Maven org.apache.hive:hive-exec: check the installed version with your package manager. - Maven org.apache.hive:hive-service: check the installed version with your package manager. - Maven org.apache.hive:hive: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.hive:hive-exec, org.apache.hive:hive-service, org.apache.hive:hive. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gf2v-9hp6-44qg (GitHub-reviewed advisory GHSA-gf2v-9hp6-44qg lists affected ranges: Maven org.apache.hive:hive >=0 =2.0.0 =0 =2.0.0 =0 =2.0.0 <=2.0.0) Commands are suggestions: review each one before running it.
Loading voting…